2

My unit is a Carrier Infinity (FE4ANF003T00ABAA) with an ECM 3.0 blower motor.

To start, the thermostat reported a “Code 41 - Blower Motor Fault”. I ordered a refurbished motor + control module online and a surge protector (didn’t have one previously) and installed it. Ran it through the 5 minute heating diagnostic with no issues, but within 24hrs it had failed with a “Code 44 - Cannot Communicate with Blower” error.

I called up the company and they sent a new control module. Before installing the new control module (on their motor, not the original), I tested for signs of shorting with the multimeter, but resistance readings looked okay.

After attaching the module and reinstalling, it again ran fine through the 5 minute diagnostic, but within 24 hours failed again with Code 44.

I tested that the board is sending 12V to the motor controller and tested with and without the surge protector.

Anyone have suggestions on next steps? Any help is appreciated!

2
  • I suppose it's possible that your refurbished motor also had a problem but I think it's more likely there is some other cause for these issues. I'd start with the basics, power and ground connections, loose connections inside the unit, etc.
    – jwh20
    Oct 15, 2020 at 13:33
  • Is there a vane switch or pressure switch that monitors the pressure? I have seen folks jump to the motor when it was a safety switch that was failing.
    – Ed Beal
    Oct 17, 2020 at 18:15

1 Answer 1

1

There was an issue with the refurbished replacement motor/parts.

I purchased another replacement motor from a different retailer and it has been working without issue for about the past year.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.