1

enter image description hereenter image description hereenter image description hereI have a Carrier weathermaker 9200 with a bypass humidifier attached. I just moved into this house a year ago and the humidifier never worked with the humidistat. I tested the solenoid by putting a 24V transformer directly on it from my sons rechargable car and that worked. It opened and water started flowing. I thought maybe it had bad humidistat since nothing happens when I turn the knob. just hear a little click. Since the house already had an ecobee I figured I could use that to control the humidifier. Ran a wire to the ACC+ on the ecobee. Connected the other end to the solenoid. Then ran the other end of the solenoid to the COM on the control board. Not sure if that is correct because everything I look up says C terminal but there isn't a C terminal only COM. Reconfigured ecobee to add humidifier as 1 wire ACC+. When I turn everything back on and start the humidifier from the app the 3 amp fuse blows. It happened twice so I guess I have it wired wrong. I currently have it disconnected. Looking for help. Thanks, Jeff

Updated: Added Schematic and ecobee connections and furnace control connections. Humidifier is a Carrier humcclbp2417 with A2012-2118 Solenoid.

3
  • Can you post the wiring diagram for your furnace, as well as the make/model of your humidifier? – ThreePhaseEel Jan 30 at 1:44
  • The solenoid went bad and was blowing the fuse. Replaced solenoid and humidifier works now. – zhouse28 Apr 20 at 20:59
  • Post that as an answer and I'll give it a +1 – ThreePhaseEel Apr 20 at 23:03
2

The solenoid went bad and was blowing the fuse. Replaced solenoid and humidifier works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.