I installed a new Craftsman garage door opener by following the instruction booklet it came with, but after the installation was done and I plunged it in the outlet nothing will power up. Nothing lit up, or any movement. I made sure the outlet was working by plugging another device, and the other device worked but not the garage door opener. any suggestions?


There are two options here:

  1. You've installed it wrong, or missed something: maybe it's as simple as a switch on the unit that needs to be turned, or the remote batteries aren't in right
  2. It's DOA, and no amount of re-configuring will work

You're going to have to go through the whole set-up top to bottom. Check all your connections, make sure that batteries are in right, that any fuses are installed and work. Then call Sears.

  • i didnt even get to try the remotes because the remote wouldnt work if the unit is not powering on..it has one button on it and i pressed that already.. the only thing i havnt messed with it the speed control.. do you think that the speen control could be the reason why the unit is not getting any power? – user9051 Nov 7 '12 at 15:20
  • A 3rd, unlikely option is that the outlet is wired incorrect and the opener doesn't like it but whatever else was tried didn't care. (But I'd guess it's installed wrong.) – Brian White Nov 7 '12 at 15:28
  • 2
    It really just sounds like it is dead, I'd call for a warranty replacement. – GdD Nov 7 '12 at 16:44
  • These sort of DIY installation guides typically have a troubleshooting guide that you should review. Then when you call Sears, you can say "Yup, did that. Yup, that too." etc. Saves time on the phone before they finally acknowledge it's actually dead and you need a replacement. – bcworkz Nov 7 '12 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.