0

I have a GE gld5660v00ss Dishwasher that no longer responds. The "Normal Wash" and "Heated Dry" buttons are lit, but no other buttons respond. The Start button does nothing, and none of the other buttons light up when pressed.

The door itself latches, and still beeps when latched but that's it.

Is it time for a new dish washer?

Looks like all the replaceable electronic components are $100+ and might not fix the problem.

I thought maybe the dishwasher was locked, and tried holding down the "Heated Dry" button for 3 seconds, but that was not the case.

Help!

  • Have you tried disconnecting it from mains power (either by unplugging it if you can or by turning the breaker for the circuit it is on off) and then plugging it back in/turning the breaker back on after 15s? – ThreePhaseEel May 29 '16 at 18:59
  • @ThreePhaseEel Yes, already tried that. – user2966445 May 29 '16 at 21:31
  • have you checked the cable between the buttons assembly and the rest of the machine? – scorpdaddy May 29 '16 at 23:38
  • @scorpdaddy Yes, just checked all cables, including removing and ensuring each one is securely attached. – user2966445 May 30 '16 at 2:57
1

It sounds like your control board is failing, considering that unpowering and repowering the unit is not getting it out of the bad state -- replacing it should fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.