0

Other day my GE microwave just stopped working. Then I have unplugged and plugged back in but still no luck. So I have used an extension chord to try on a separate outlet and it powered on but ran just 10 secs or so. Checked main switch board and found Microwave fuse got tripped. So turned it back on and tried with original power outlet and with extension chord, no luck. Then I confirmed both power outlet using a small portable fan and it worked. So outlets are good but Microwave is not powering on. In the mean time I have changed two fuses inside microwave to see if that helps or not but no luck either.

From above description of the problem, does it sound like capacitor problem? Is it worth fixing it? BTW, its just 5 years old and was taken from builder.

Would appreciate any honest opinion. Thanks,

Moh.

1

I'd be more inclined to suspect a bad interlock or possibly a dead triac than a capacitor failure -- either way, microwaves are best taken to a service tech to be serviced (they're one of the few household appliances that contain a truly lethal HV supply in them).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.