I have a ceiling fan & light that is controlled by a wall switch. Recently, I went to turn the lights on and they flickered but didn't turn on. The fan works fine.

I decided to replace the switch with a new fan control and dimmer and the connections lined up with red, black & white wires. I turned the power back on and the fan worked - lights didn't.

So, I decided to replace the light kit and the connection worked fine (one white & one black). Turned the power back on and same issue.

The next day I woke up and switched both the Fan and Lights all the way on and THEY BOTH WORKED! Essentially, I learned that if the fan is turned up all the way - the lights work.

Any idea on why this is and what I can do so that they both work?

One PS to this - I noticed that there is a quiet slight buzzing to the switch when it is turned on.

  • Can you give us photos of the insides of the boxes? – ThreePhaseEel Apr 14 '16 at 23:18
  • I think I solved it. I added my solution below. – rmlumley Apr 15 '16 at 2:26
up vote 2 down vote accepted

This was the solution that worked.

SWITCH ---------> OUTLET

Yellow ------------> Black

Red---------------> Red

Black ------------> White

This was the solution.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.