0

enter image description here

I have a Delta kitchen faucet that began leaking many months ago. I tried to fix it today so I'm following instructions online that tell me to take out the spigot so the o rings can be replaced. Unfortunately, this spigot wont come out. I've tried pulling it straight up, tried prying it out, tried using wd40 on the bottom since it does lift out for a small gap then wont move any further.

enter image description here

On the back there's a word that says C 150 series. I see no screws or anythign of the sort to take out the spigot, and twisting clockwise or counterclockwise does nothing.

How do I get the spigot out in this case to gain access to the O-rings?

1

Looks like all I needed to do was wait a little longer. The WD-40 did its job and there was lots of corrosion in the spigot at the bottom where the spigot ring met the spigot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.