I have been having problems with my Genie SilentMax 1000 garage door opener. With the door disengaged from the opener the shuttle moves back and forth about 4" and stops. It has been doing this intermittently for a month or so now and then sometimes it starts working again after I try it 10 times or more.

  • The door operates quite easily by hand with no restrictions.
  • The safety beam is not blocked and has a constant light.
  • I have reprogrammed the up and down limits twice.
  • I have reprogrammed the up and down force to maximum.

I can find parts like here: http://www.genie-garage-door-openers.com/genie10003024.htm

It seems the motherboard is $75 about half the price of a new door opener. I am wondering if anyone else has seen this problem and if they successfully repaired it with a circuit board or was it the motor.

I hate to buy a part and have it still not work but I hate to completely replace the opener. It is only 18 months old, just past warranty, go figure huh? I won't be buying another Genie.

Thanks for any help and happy holidays.

4 Answers 4


After discussing this with the Doors Unlimited Sevice tech I opted to have the opener replaced. We agreed it could either be in the rpm sensor or the mother board but either way replacing it was the only sure way to fix it.

I will not ever buy another Genie door opener.

  • That's quite uncommon. But, I'm glad you're tossing the Genie. I tried a pair of their Accelerator models many years ago, when they first came out, & problems galore after the first month of being awesome.
    – Iggy
    Commented Mar 7, 2016 at 3:12

Remove as much of the casing as you can without taking it down from the ceiling, and look at the insides each time you use it. 4" sounds plausibly like the circumference of some gear or mechanical component that might be jamming inside the machine.

  • Thanks for the idea. I need a taller ladder to get above it and won't get to it for a week now. I will try to dissasssemble the top of it to see the gear. Maybe it is binding. The error code flashing on the LED says something is wrong with the door hardware, but I can raise and drop the door with one hand and it moves quite easily.
    – ArchonOSX
    Commented Jan 4, 2016 at 20:04
  • Disengage the trolly, and then (carefully) try to move the door up/down by applying forward and backward force to the loose trolly. Perhaps it opens fine by hand on the middle of the door, but it binds up when pushed by the trolly. I still think its more likely a mechanical problem inside the opener chassis. Commented Jan 5, 2016 at 3:58

I'd agree with BillyCrook (the drive gear), if you have to buy the whole motor for it just get a new GDO. But also check your trip beam or Safety Sensors. Are they clean, cleared of obstructions & aligned to each other, clip-ons tend to move.

  • Thanks I will check the pass transmitters again for alignment but last time I checked they had steady lights.
    – ArchonOSX
    Commented Jan 4, 2016 at 20:01

I would suggest a failed DC Opto. The part is cheap and easy to replace.

  • 1
    Hello, and welcome to Stack Exchange. You may be right, but it's hard to tell given how little information you include. Editing your answer to include more information would really help. Commented Nov 10, 2016 at 11:31
  • It would be help full to describe the the type of opto parts you are talking about ( safety sensors at the bottom of the door) and you could include things like one is usually a transmitter and 1 is a receiver. Many times they are DC but there are many that are AC. Also misalignment can be the cause of the failure.
    – Ed Beal
    Commented Nov 14, 2016 at 19:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.