1

I've got a well system, with a standard 10-inch filter housing between the pressure tank and the water softener.

The filter housing is plastic, and there are shut-off valves on either side. I religiously change the filter once a month, but when I tried to loosen the housing recently to replace the filter, I could not get the housing loose.

I tried some Russian diplomacy but it won't budge. I'm afraid to use too much force because I don't want to (a) rip the housing loose from the wall or (b) mess up the input/output lines attached to the housing.

Any ideas? I guess the nuclear option is to install a whole new filter housing, but I was hoping for a trick to loosen the existing one.

Thanks!!!

  • Have you tried relieving the pressure? i.e. turning off the water and opening some faucets – Steven Sep 30 '15 at 14:29
  • Yes... the housing has a red pressure-relief button. It's definitely not water pressure that's holding it on so tight. – MGS Sep 30 '15 at 14:38
  • A photo would help. – BMitch Sep 30 '15 at 14:49
  • It's almost exactly like this: photo – MGS Sep 30 '15 at 15:19
  • I'll post the resolution... it took two burly well drillers with a chain wrench about 10 minutes to break loose the housing. Many colorful words were spoken during that time. They had no idea why it was on so tight, although they said I must have eaten my Wheaties the last time I changed the filter. – MGS Oct 8 '15 at 16:10
1

Those little red buttons quit functioning with age, and crappy water. Open a faucet, and turn supply off. A slight coating of petrolium jelly on the o ring works wonders as well. Use very little, just to the point of adding a sheen to the rubber.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.