1

When I click the remote open/close button, it doesn't react (no sound) at all. I tried from several remotes, nothing happens. The wall control also has a light button which is working fine (meaning it turns on/off light on the base). It's not sensor issue since they are solid. The motor is not humming. Open up the control box, the green sensor light is blinking slowly. Never had such issue before, and it happens suddenly. What might be wrong?

  • What is the make and model of the opener? Does the user manual say anything about what the slowly blinking light means? – Tester101 Jun 1 '15 at 12:08
1

Okay, I figured out on my own. I found the user manual for my model (Genie ISD990), and the troubleshooting section says "reset opener - unplug" if status light is blinking (1 blink). I unplugged the power, wait for a few seconds, plug it in again and it works now. Don't know what has caused this. This opener is at least 10 years old, but never had any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.