5

The vent hood is quite old. For some reason when I flip the switch to turn it on it takes 10-30 seconds to actually turn on. I've checked it and there's no power flowing for those 10-30 seconds. There's no sound during that time or any indication of what's going on. At first I even thought it wasn't getting any power until it suddenly started after I'd left the switch on for a bit. I mean, its definitely not getting power for those few seconds but I thought it was a dead motor or something at first.

It always does this, even if it was just running. Turning it off and then on again will cause it to stop and take its time to turn on again.

I'm fairly decent at DIY household electricity, but I've never encountered a problem like this. It defies my basic understanding of electricity. I think it might be the switch but I don't know how to check for that and don't know what to do to replace the switch on an old stove range if it is.

  • 1
    If it is that old could the switch be gunked up inside causing it to react slowly? – Speedy Petey Apr 6 '15 at 23:35
  • Well, I'll be pulling it apart soon. I'll post here if I figure out what is wrong. – user3001120 Apr 8 '15 at 1:37
  • 1
    When opening up try to manually bypass switch to see if that starts it up immediately. If it does, remove switch and test it. – Joop Apr 17 '15 at 8:30
  • 2
    How did you determine that "there's no power flowing for those 10-30 seconds"? – ESultanik Apr 30 '15 at 15:24
  • 1
    Multimeter. It has no voltage reaching the fan for 10-30 seconds after flipping the switch. Then it suddenly gets voltage and begins spinning. – user3001120 May 1 '15 at 17:12
1

Probably kitchen gunk on the switch contacts. It takes that long for the contacts to "sink" through the gunk. Replace the switch,

0

If you know the brand name, you can look up the technical specs even for discontinued models. Usually it will be a PDF file that includes a schematic. It does sound like an electrical problem. It could be something like a cracked solder joint that expands and connects after heating up that initial thirty seconds.

0

It may be that your start capacitor is dying out. If it works when you turn it on, then it can't be a contacts issue. It's possible the windings in your motor are wearing down or shorted, hence the extra current draw and the delay. Again you might have a ton of gunk in there.

0

It is most likely one of your capacitors. Some single-phase motors (which your fan has) have just a Start Capacitor and some have both a Start and Run capacitor.

A motor circuit is simple. A couple switches, a couple capacitors, and the motor windings (inductors). If your fan still works after start-up, it's almost certainly not the windings. Windings are delicate and there's no real "half broken" mode. Switches are simple and they do have their problems, but they are usually obvious when their broken. They'll either not turn on, pop loudly and not turn on, or fizz and crackle and not turn on.

Capacitors are complicated works of engineering and are more likely to degrade over time. They have a very specific chemical inside of them (be careful if you see any leaking out; it could be harmful), are dependent on very small pieces of metal very close together, and are affected by temperature.

The inspection process for a capacitor by someone who is not a pro is simple. Pros can do a better analysis, but with how cheap those fans are these days, it's not worth hiring one.

  1. Capacitors (in this capacity) are cylindrical and range from 3/8" diameter to upwards of 1-1/4". Find the one or two biggest capacitors on the electrical circuit board inside the hood somewhere.
  2. Look for puffed up tops, splits in the sides, goop dripping out, black burn marks, and other obvious damage.

If one of them is damaged, carefully look on the side of it for it's "size." It should say something like "150v 10uF". At this point if you don't know how to solder or don't want to try learning, look up a business near you that deals with "ham radios" or "CB radios". Take the board in and nicely/humbly ask if they could help you. They'll be able to find the part for you and install it.

Post back if you have any questions in this direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.