I am trying to manually cycle through my sprinkler zones with my Rain Bird ESP-6 controller (from 1996), but the membrane button to manually cycle the zones does not work. In fact, none of the 4 membrane buttons work. But the dial works fine and the system still runs when it is supposed to for how it is currently programmed.

I have tried taking out the backup battery, unplugging the power to the controller, and re-plugging the controller without the battery, but it did not work. I also completely dismantled it, cleaned it out and inspected it. There were some insect carcasses inside the controller and a bit on the circuit board, but nothing that appears to have caused any damage or short-circuiting. I don't see any indication of burn marks or overheating nor do I see capacitors that look (visibly) blown.

I do remember that the last time I was cycling through my zones, about 3 months ago (just to inspect them and adjust the nozzles) I had some minor issues with the manual cycling button. It worked, but I had to press a bit harder, and sometimes it didn't register. I don't know if the other 3 buttons had identical issues at the time, I had no need to press them.

Is it safe to say that I need a new controller, or, in the least, need a replacement circuit board? Now that I have reset the controller, I currently cannot program it for the hot weather coming. I'll just have to manually open bleed valves until I can remedy the situation.

3 Answers 3

  • If the membrane buttons are on the circuit board, a new one might fix it.
  • On the other hand it's an electronic device that's 19 years old. Assuming you can even get a replacement part, it will probably cost a significant percentage of just replacing the whole thing with a new unit (and typically the new unit will have a warranty period, while a replacement board may not.) Go shopping for both ways and make up your mind.
  • A third possibility would be to see if you see anything that you might try when you search for "membrane keyboard repair" - I have not sifted through the results, and I'm not going to link to any, but there did seem to be a variety of options such as replacing the unreliable things with reliable types of switches, and various attempts at opening them up and cleaning them. I'd prefer replacement (not a fan of the things, longevity-wise), which should be as easy as wiring 4 switches into the place where the membrane switches connect.

Mine does the same thing. I have to remove everything until the foil spots are exposed. Then I can press really hard with my fingernails to get the switches to increase/decrease minutes, etc. It takes about 30 minutes to complete the task, but I only have to do it twice a year. I guess I should buy a new unit, but this work-around has worked for three years. You might give it a try. I also cleaned with alcohol.


Had the same issue, none of the buttons responded and the display just showed 'power off'.

Removed the face plates and disconnected the internal battery. When re-connecting it, the fuse blew. There are replacement fuses on the back side of the faceplates. Replaced the larger fuse and everything worked as it should. Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.