1

We have a Utica Boiler model number SFH4150WT and we are receiving hot water but the radiators do not heat up!!. We tried bleeding the radiators, they only heated up a little bit but after about 5 min went back to being cold. The pipes by the furnace heat up but not the radiators upstairs. I read the pressure and it is below 5 psi. This all started after a radiator pipe broke in the garage but we fixed that too and still no luck! Any help would be great I have a 2 year old in the house and I don't want her to suffer any longer. Thank you

  • 1
    You're not giving enough information. Is this hot water or steam? Is there a pump or does the water flow by convection? Is the PSI is low why did you not add water? – Ariel Jan 12 '15 at 1:43
0

You did not give enough information (see my comment). But here is a guess for you anyway:

5 PSI is equivalent to 11.5feet of water. To me that means your radiators are filled to that height above the gauge and no more. (i.e. if the boiler is in the basement probably only the bottom of the radiator has water.) So no wonder they are cold - there is no water in them to carry heat.

But this is just a guess.

0

Assuming your pressure guage is correct, you should introduce more water into the system. If you have a pressure regulating valve on the input side, ensure that any valves going into or out of it have been opened.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.