1

I have a Samsung clothes dryer that stopped heating up. Here's what I've tried so far:

  • verified that the 30 amp breaker is working fine
  • verified 120/240v at the relay
  • verified 9ohms across the heating element
  • verified that the element wasn't shorting against its housing
  • verified 0.1 ohm at the high limit cutoff and the thermostat
  • verified the thermistor on the control panel is functioning correctly
  • gave lint trap, exhaust, etc a good cleaning

About the only obvious thing I haven't tried is probing the outlet itself for 240v. I'm unable to check it with my multimeter because the probes can't reach inside the outlet. That said, sine the relay read 120/240 as expected, I think it's getting good power.

Final weird thing is that after I put the dyer back together and it didn't work, I flipped the breaker off and on and tried the dryer again. It heated up! Power cycled the dryer and tried again, no heat. Toggled the breaker... Heat! Power cycled and got no heat. Figured I was on to something, but no amount of fiddling with the breaker or power cycling will make it heat up again. Really not sure if that's a red herring, but including it for completeness.

So - any suggestions as to what the problem might be? I guess I feel like I've tried the obvious things, and now need some less obvious possibilities.

Thanks

4
  • 1
    Sounds like the relay may be sticking... or there's some other flavor of intermittent connection.
    – keshlam
    Dec 17 '14 at 4:02
  • You are aware that you have 2 limit switches on a dryer right, one on top and one on bottom, double trouble :) what you need to buy is an amp meter, where isn't voltage flowing brother man
    – user70085
    Oct 20 '18 at 3:57
  • I had one go bad from a similar issue, I took it off and threw it on the pavement (flat part down) got it unstuck and worked again for a few for months :)
    – user70085
    Oct 20 '18 at 5:50
  • Did you ever get this resolved? If so, please give a check-mark to the answer or write up your own answer explaining what you did to get it fixed and give yourself a check mark. That will help others with this kind of problem know that this has a resolution and is a good place to look for their answer.
    – FreeMan
    Aug 14 '20 at 11:26
0

probably a bad circuit breaker, recommend replacing it. You can check if it is bad by checking the voltage on it using an ohm meter. Set the ohm meter to 200v ac, touch one probe to the screw where the wire is attached and the other probe to the silver grounding bar with all the bare copper wires attached. It should read approx 120v. Check both wires this way. Start the dryer, if it doesn't have heat again... recheck the voltage on the breaker again. I'm betting that one of the screws shows 0 voltage... my guess is that one leg of your breaker is bad or faulty.

2
  • 3
    Given that there is 240v present inside the dryer, it's unlikely to be a supply issue. Jan 22 '18 at 4:49
  • Chuck If there is any connection between phases such as a heating element your test will measure OK even if one of the breaker poles is open. I prefer using a volt meter or multimeter, many ohm meters will not survive that voltage. The best test is between the two poles of the breaker, he should get 240V.
    – Gil
    Aug 9 at 16:56
0

I had an issue like that on a Maytag a few years back. Power good, thermostat good, fuses good. Turned out that if I really pushed on the timer knob, it would heat, and then eventually that stopped working too. replaced the knob, all good since then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.