2

I just replaced my refrigerator (RFG297HDBP) water filter with a genuine Samsung replacement filter. However, with the new filter in, I get a short burst of water, then no more water. I can pull out the filter and reinstall it and the same thing happens ( I have pulled it out and screwed it back in about 20 times so far). I put the old filter back in and now it is has the same problem. My guess from the sound of it is that the filter is filling up with water during the turning process, but once it gets to the lock, no more water is able to pass into the filter. Has anyone else experienced this? How should I fix it?

  • Facing exactly same problem, without filter water is flowing correctly and once installed does not dispense, can someone post photo of that hot glue option, i wanted to try that and does not want to ruin the brand new expensive filter by doing it wrong. Thanks in Advance. – user81499 Feb 12 '18 at 3:19

10 Answers 10

2

We had the same problem as everyone else. Installed a new filter (not a Samsung filter). After we installed the new filter there was no water. Tried the old one again and same thing, no water. We tried everything and could not figure what the problem was. Finally we unplugged the refrigerator and waited a few minutes. Plugged it back in and voila, we had water! Evidently something needed to reset itself.

1

Here's what I found. I tried installing another brand of filter. When I put in in and turned it, it broke off one of the star-shaped, spring-loaded valve stems that controls the flow of water in and out of the filter. If you look back inside the filter (the filter housing), there should be two of these valves. My cheap filter broke one of these. I'm looking into ordering the filter housing myself and see if I can do the repair.

  • Mine did not appear broken, but since I tried multiple filters, it had to be the filter housing. Since water still flows when a filter is not inserted, my solution was to buy an external water filter on Amazon and hook it up between the water line and the fridge instead of spending the money on a new filter housing which isn't cheap. – yellavon Aug 10 '16 at 14:35
1

I had the same problem. I use generic filters. One time I got no water after changing and the old filter would not work either. Tried multiple times to get it to work. Finally just removed filter, closed door and ran a glass of water without the filter. Bingo, put filter back in and worked IMMEDIATELY. Assume there was some sort of air lock and that flushed it. I would also pre-fill the filter before inserting it.

1

What I did was remove the 49 dollar 300 gallon filter. Then I installed at 32 dollar 6000 gallon 5 year in line filter on the line leading into the refrigerator. The filter head assembly is a design defect. I won't pay 160 dollars for replacement of the assembly so I can continue buying Samsung filters. So... solved two problems and Samsung just lost business in selling their 49 dollar filters. It was a win win for me and a lesson to Samsung that if they want to sell expensive filters they better make sure the check valve pins in the filter head don't wear out early.

0

Here is the answer to the question.

When you changed the filter and put the new one in, the one or both of the valve stems broke off. You can replace the filter housing for about $170 or do a poor mans repair.

I looked where my filter goes in and saw that the outside valve stem was slightly shorter than the inside one. So I took a hot glue gun and put some glue on the flat part of the filter that touches that stem. By the gaskets. Let it dry and get hard. This will push the stem all the way in. Put the filter in and it all worked again. Cost, 1 cent. Call the repairman, $200 to show up and $200 for the part.

This is what is wrong with your water.

0

Same Problem Solved. Turn off water. Take out filter. Turn on water. Run water for long enough to fill the supply tubing. Shut off water. Install filter. Slooowwly turn on the water while someone else is drawing water. Worked for me. Thanks

0

So, This has been driving me crazy for 2 years now. The only fix that i found was to take a hot glue gun to the new filters and put a small dab of glue around the inner and outer rims that push the X plunger into the filter housing assembly(props to Pete). I have the Samsung french door fridge and use the DA29-000029B filters. If i don't use filter I get a perfect water stream. If I press either plungers boom water in my face. Nothing looks broken, and after doing the hot glue it seems like its a filter manufacturing tolerance issue. Where when turned in till it locks, it does not fully depress the plunger(s). This is why my original one worked, and replacements don't. Also this explains why sometimes it works for a little bit then gets slower and slower and stops as the plugged works its way out with vibration. Worked for me and i just hot glued three filter replacements so i wont have to do it for a year and a half. Either try that, spend $200 on a new filter housing assembly (that may not fix it) or say screw it and get an inline filter.

I hope this helps at least one person driven to the level of insanity I was.

Last ditch effort is to unscrew the filter but leave it in so it looks like its filtering and just reset the light when it turns red. This will keep the wife fooled for awhile. :P

0

I've been going a round with this fridge and filter issue since moving into a rental in August. Finally tried to insert the filter simultaneously while depressing the water lever on the front of the fridge. The water kept flowing through the filter once it was locked into place and no stoppage thus far! Hallelujah.

Good luck. YMMV

-1

I had the same problem. Have you resolved the problem? I went to Samsung.com and the site suggested running the water without the filter installed. If you have water then it is not the line or the unit it is the filter.

  • Yes, water is dispensed without a filter. However, I tried reinstalling the old filter after the new one didn't work and it wouldn't dispense water anymore. So it is an issue with the locking mechanism which controls water through the filter. – yellavon Dec 24 '14 at 2:01
-2

The answers is to wait about 10 to 20 minutes and water will start to flow. That is it.

I tried this after uninstalling and reinstalling the filter many times, finally I waited 20 mins after installing before trying to dispense water and it worked perfectly.

protected by Community Feb 12 '18 at 13:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.