I'm recently having trouble with a water heater. The pilot light with ignite just fine, but will go out after releasing the reset button, even after holding it for over a minute. That makes me think the thermocouple is bad.

In addition to that, the hole where the brass nut that holds the thermocouple in place is stripped out. I cannot get the nut into the hole. I tried holding the thermocouple in place with my hands and also with strands of duct tape and the pilot would still not stay lit.

But would the pilot stay lit if the bolt were not in place, or does the bolt serve a purpose other than securing the thermocouple that allows it to function?

3 Answers 3


To be clear for future searchers: the nut is critical, it provides half of the electrical connection.

A thermocouple requires two wires to function: electricity is generated at the junction of two different metals and two wires are needed for current to flow. While some thermocouples have two wires, the original poster is talking about a model with one wire. The case of the thermocouple must firmly contact the frame of the furnace, to complete the circuit. Consider buffing the furnace frame with steel wool to remove rust and scale.

  • This is the exact thermocouple that I used.
    – user19565
    Jan 29, 2014 at 20:00

Do you have a multi-meter? If so, test the voltage output from the thermocouple when heated by the pilot. Set your multi-meter to DC and the lowest voltage it can measure - the output should be at least few hundred millivolts. You can consult your furnace documentation for the minimum voltage needed. You can perform this with it held in the correct place versus unsecured.

If the threads are stripped, you're probably best off replacing it anyways. It's a cheap part and easily replaceable.

Also check to see if your heater is equipped with diagnostic LED's and if so consult the error sequences in the user manual.

  • No, I don't have one. I did replace the thermocouple anyway, though it may have not been broken. The threads on the thermocouple were not striped out. It was the threads in the socket where the thermocouple goes. That looks like an expensive part to me. If you see my own answer you can see that I came up with a solution.
    – user19565
    Jan 29, 2014 at 3:56

Apparently the nut only serves to hold the end of the thermocouple in the socket firmly.

It really needs to be held in quite firmly. I managed to keep the pilot lit while holding the thermocouple with my hand, applying a good deal of pressure, but when I let go of it, the pilot would go out.

I managed to overcome the problem by screwing in the nut at an angle and only half way up (essentially drilling new threads). Before screwing it in, I placed a small piece of electrical wire casing around it to give pressure from the nut to the end of the thermocouple. The pilot remained lit for about five minutes until I switched the heater to on and turned up the thermostat. Then, as expected, the heater ignited and began to heat the tank. The tank heated as expected and the pilot light remained lit.

  • A month later and no problems.
    – user19565
    Feb 26, 2014 at 4:51
  • Over a year later and no problems.
    – user19565
    Jul 13, 2015 at 15:07
  • I moved from that house in April 2018. It was still working without any problems at that time. Four years is pretty good.
    – user19565
    Apr 8, 2019 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.