I have an Ariston Eurocombi (A23). The problem is it doesn't realise the flame is lit. When I start it up and cause demand (run hot tap or turn on heating) it fires up the flame correctly, however, you can hear the igniter still clicking away. After about 7 seconds of this (flame working correctly, but igniter clicking) the boiler then shuts itself down and lights up the "Ignition failure" light. I can press the reset button but the same thing just happens again.

I don't think the problem is related to over-heating because if I leave it alone for a few hours, then try running hot water again, the problem is still there. However, If I turn it off, and off at the wall, then wait for at least an hour or so, I can get it to work again for about 1/2 an hour.

I assume the problem is either with whatever detects the flame is lit, or the board that responds to that sensor.

Any suggestions for how to diagnose (or better still, fix) the problem?

Thanks, Matt

4 Answers 4


I believe it is fairly normal for the igniter to continue to fire for several seconds after ignition, I guess this is because it takes a while for the flame sensor to heat up - and probably also for performance/safety reasons.

Boilers have a flame-sensor, it sounds like your has failed. You can buy replacements.

I think this is a job most people leave to a boiler service technician, you need special tools (e.g. multimeter with microamp range) to check those sensors.

Gas appliance repair is safety critical, probably best left to those with training and experience.

enter image description here
19 = "detection electrode" 20 = ignition electrodes. See manual

enter image description here
A07 = flame detector. A09 = flame detection circuit. A10 = flame indicator LED - I'd check this is "on" after 5 seconds of successful ignition.

Don't rule out other causes, boilers shut themselves down for lots of reasons, maybe the flue is iced up or the water pump isn't operating.

The manual contains a troubleshooting flowchart and a parts list that includes the flame sensor.


I have had the same issue with my boiler as many people have with the Ariston Microgenus. In fact Ariston have modified the PCB (circuit board) and changed some components to resolve the issue. If you have an older model like me and don't want to spend the 160 pounds for a new PCB. I worked out the easy fix which I've made a video for and posted to youtube: https://www.youtube.com/watch?v=u-L3PzGQAa4

  • 1
    Can you summarize the contents of the video here, in case the link breaks? Nov 18, 2016 at 12:44
  • a summary would be good but + for the effort.
    – Ed Beal
    Nov 18, 2016 at 13:52

Short answer: The flame sensor has become coated in carbon and is not sensing that the burners have fired. You will not see the build up as it is an invisible coating. The flame sensor will need to be cleaned. It is not recommended to use sand paperer grit cloth to clean them as this will create grooves in the sensor, and will cause it to carbon up much quicker. You should use either ultra fine 000 or finer steel wool, or paper. Technicians will commonly use money when regular white paper, or steel wool is not available.

All repairs and service done to any gas fired appliance should be done by a licensed technician

  • I agree that its the flame sensor, but they can also be cleaned with isopropyl alcohol. This repair doesn't require much more than removing the front cover and the flame sensor, I don't know of any reason it shouldn't be DIY.
    – Steven
    Jan 4, 2014 at 2:30
  • From my experience, if the homeowner is not technical they should not attempt this. Some appliances are easy to remove and clean, some are not. I have seen homeowners break the sensors, or accidentally remove the ignitior, and break it in the process of trying to clean it. Another reason is that the flame sensor getting dirty may be the cause of an issue with the equipment, or how the equipment is being maintained. Although this is rare, it still happens. I also agree with the alcohol. However, most technicians wont carry this around. Steel wool is multi-functional and works for me.
    – Mnc123
    Jan 4, 2014 at 6:38

I tried cleaning the detection electrode as suggested by @mnc123 but no effect. Ended up just getting british gas round.

Problem was solved by replacing the motherboard (the one on the right).

Thanks all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.