2

I am currently having some issues with my Hot Springs Sovereign hot tub. Well, actually just one issue, it is cold.

Some more information on the tub. I am sorry to say, it has not been maintained too well. The tub belongs to my roommate and he got it used about 1.5 years ago and we have been learning proper maintenance as we go. The filters were old and hadn't been replaced or cleaned in some time. I am worried that this might be an issue.

This has been going on for some time now. I first noticed that there were no more bubbles (ozone) coming out of the central drain, and the tub was warm, not hot. The first thing I did was replace the thermistors. Upon replacing both thermistors, I didn't notice anything. I then suspected an airlock so I ran a hose down the central filter and that pushed a lot of air out of the central drain and appeared to restart the tub. Unfortunately, I had installed one of the thermistors without a silicon o-ring and it was leaking a little. When I tried to tighten the thermistor in order to stop the leak, I ended up stripping the damn thing and had to drain the tub and order another one.

After I installed a replacement thermistor and refilled the tub (by running a hose into the main area and not through the central filter intake.. oops) the tub was not still not heating. I then tried to flush out any air lock with a hose again, but no bubbles came out this time. I then suspected that the circulation pump was not working optimally, although it hummed to the touch. I just replaced the circ pump a few days ago with no change.

The heating element was replaced within last year and the light is lit up on the circuit board.

I suspect that the issue is somehow tied to the water not circulating properly but I am not sure what to do next to further diagnose or fix it. Any help would be greatly appreciated. I will probably try some of that spa cleanse stuff next to see if I can clean out the pipes.

UPDATE: I tested the power to the heater with a volt meter and it read 122V (the tub is running off 110V so within normal range). It is a no fault heating element.

UPDATE #2: A repairman came out and "fixed" the tub by hitting the reset button on the outlet... This was something I had done quite a few times, so I don't think it really addressed the initial issue. Sure enough, the tub stopped heating about a week ago. Both the heater and circ pump hum to the touch, but I dont feel any water coming out of the central drain.

  • How long have you waited for it to heat up? It could take the better part of a day to heat the tub. – Tester101 Oct 22 '13 at 11:16
  • Look down in the equipment area. There should be valves on the pumps for helping remove airlocks. And it's ok to just fill to the seating area. The water will flow everywhere it can. Sending water right down the central intake can cause the pump impellers to spin and potentially damage the pumps. – Tom A Oct 23 '13 at 16:31
  • @tester101 Its been days so time is not the issue. – Sobewine Oct 31 '13 at 3:47
  • @Tom I will look a little closer for a valve on the circ pump this weekend. – Sobewine Oct 31 '13 at 3:48
  • 1
    OK. So shortly after I posted this I had a repairman come out and take a look at the unit. Turns out he just pushed the reset button on the GFCI and it started working again (something I did everytime I futzed with the thing)... Anyways it was functioning fine for 2 months and then last week stopped heating again. So back in the same boat. – Sobewine Feb 10 '14 at 22:08
1

Not sure if this helps but I ran in to something similar. If your tub gets too hot, it might go past its heat limit and stop heating all together. There should be a high limit reset switch that you'll need to hit to get it heating again. Just adjust the temperature setting so it doesn't hit the limit. Mine was showing that it was heating on the top panel, but wouldn't start heating until I reset the limit switch. I had prior work done to it and the tech cranked the heat all the way up to test something and I overlooked it once we got it going again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.