I haven't used my well pump all Summer (since we've had to much rain I've not needed it). This last week or so things have really dried up and I decided I should water the grass. With sitting that long I went ahead and re-primed the pump (I know from the past that it can only hold prime for about 2 weeks of disuse). No problems cycling it several times while priming.

I then let it finish refilling the tank while I ran the hoses out in the yard. When it clicked off, instead of the usual "click"/"whirrrrrr" sound (from the motor spinning down) it made a "click"/"pssssshffft" sound. I didn't think a lot of it as I had the primary valve open and sometimes there's a little leakage around the secondaries. However, after attaching the hoses and opening the water valves the tank drained without the pump ever coming back on.

So far I've checked power to that circuit, and tapped the control module to see if it might perhaps be a stuck relay. What should I look at next? Pressure switch (if so, how do I test it?)? Bad motor perhaps? Any particular common point of failure (especially with that odd sound)?

1 Answer 1


Before I tried calling the once local electric shop I trust and the one local well pump shop in the phone book I decided to go ahead and take a crack at it myself. I assumed either the motor was toast or the start/stop switch/pressure assembly was bad.

I opened up the casing (with the power cord unplugged of course!) and found that the pressure switch (under pressure) forces the contactors (no true relay, has open air contactors) apart. With no pressure in the system, they were firmly closed. The module did have a number of bugs in it, so I forced the contactors open and cleaned them off. I then scrubbed out the bugs from the rest of the control module, manually clicked the contactors a number of times (and they made a nice solid metallic click). After that it was re-assembly and test time. Hooked everything back up (pipes and all, since if it works I don't want to either run it dry for long or have to yank the plug out while it's pulling a full 3/4 hp worth of power (12 ish amps).

Did a full prime cycle and then multiple test cycles with no problems. Ran out all my hoses and sprinklers and let the water flow. Works perfectly now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.