Yet another GFCI tripping post. My issue is that I have a new installed 20A GFCI receptacle that is tripping as soon as I turn the breaker on without a load attached. I've done everything I can think of to test what is going wrong with this and I am at a loss. Since I know you'll ask, I have:

  • Wired LINE to the panel (Brass to hot/black, Silver to neutral/white, Bare wire to ground screw)
  • Left LOAD unconnected.
  • Checked with a multimeter for resistance between hot-neutral(O.L), hot-ground(O.L), neutral-ground(0.1 ohm)
  • Checked with a multimeter for voltage between hot-neutral (123VAC) and hot-ground(123VAC), neutral-ground(0VAC)

Besides this thing tripping without a load connected, I'm also not sure about neutral to ground continuity. I've read that neutral to ground can cause a GFCI to trip... but I've also read that they are supposed to be tied together in the panel to maintain the return path... So I'm confused.

This is the second new GFCI I've tried in the past 2 days - thinking that it was a faulty GFCI. There are other GFCIs in my house that work just fine - and I cannot tell what the difference is in the panel wiring between those GFCIs and the one I'm currently installing.

Here are the things I've "read" as far as GFCI tripping causes and the neutral-ground bonding in the main panel:

Why is the neutral tied to ground in my home's electrical panel?

Why would bridging Neutral and Ground trip a GFCI breaker?

The romex from the GFCI to the panel is easily traceable, and I've included some pictures below of the GFCI wiring and the panel wiring, as well as the wiring of the GFCIs that are working fine.

Overall my question(s) is: Why is my GFCI tripping without a load attached? Does this have to do with the neutral/ground bonded at the main panel? Why do the other GFCIs work fine and not the one I am installing? Is there something else I should check to provide more information or troubleshoot this?

Thanks for any feedback.


  • Yes, I did press the reset button after supplying power to the GFCI. Plugs still do not have power and the reset switch stays red.

  • The receptacle is the Eaton GF20W.

  • The box I am using is plastic. No metal inside.


I swapped out the Eaton brand as per @Robert Chapins suggestion for a different brand of the exact same product (Leviton) and that worked. I have no idea why, but it works.

Picture of the back of the GFCI causing issues.


Picture of the front of the GFCI causing issues.



Picture of the breaker that the GFCI is connected to. It's the one that is flipped off.


Overview of the panel wiring with the two working GFCIs marked with red boxes, and the problem GFCI marked in another red box (sorry for fuzzy text).


Picture of one of the breakers that has a working GFCI receptacle.


Picture of another breaker with a working outdoor GFCI.


  • Please add the model/part number of the receptacle. Commented Jun 30 at 0:43
  • Please also add any relevant details about the accessory ground bar. Commented Jun 30 at 0:45
  • @RobertChapin Updated. Also which relevant details are you looking for? Like a closer wire diagram? Commented Jun 30 at 1:30
  • 3
    The neutral-ground bond in the main panel is not causing your problem. Neutral-ground bonds elsewhere, or neutrals shared between different circuits do cause problems.
    – Ecnerwal
    Commented Jun 30 at 2:38
  • 4
    If you swap the problem GFCI receptacle with one of the working ones does the problem move with the receptacle or stay on the same circuit?
    – HABO
    Commented Jun 30 at 12:58

2 Answers 2


Only 2 clear ways to go about troubleshooting now.

Some devices have a very stiff reset button. Make sure it's bottomed out, even if you need to use a hand tool to mash it in there. We haven't seen where you're mounting this device. If it's a metal box, make sure the fit is appropriate and nothing is touching or arcing on the sides.

If it really won't reset then try a different brand. I haven't seen that particular problem myself, but definitely had other quality issues where I sent multiple receptacles back to the store.

  • Wow yes this fixed it for me. I switched the Eaton GFCI for a Leviton GFCI and it works now. I immediately drove down to the local store and got a new Leviton 20A GFCI and it works! I have no idea why the exact same product from a different brand works...but I guess that's how it goes. Thank you. Commented Jun 30 at 23:31

Did you read the instructions that came with the receptacles?

Tripping on first power-up (as a mandatory self-test) is normal behavior for many GFCI receptacles. If it stays reset after you press the reset button, it’s all good.

The neutral/ground bonding (which is correct) is irrelevant. The GFCI electronics do not connect to ground at all. They don’t care if ground is present or not, hot and neutral are reversed, etc.

  • Hi, I failed to mention that. Yes i did press the reset button, and no that does not fix the issue. The plug has no power after pressing reset and the button color state stays red. Commented Jun 30 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.