I've got a Goodman forced air gas furnace. It's about 17 years old. It recently tripped the flame roll out sensor. About 2 or 3 weeks ago I replaced the ignitor on this unit, and it's been working fine since then.

So I took the cover off, reset the roll out sensor and ran it through a cycle to see what's going on. Sure enough, two of the four burners aren't going into the heat exchanger, and are burning outside - and are therefore tripping the roll out sensor. Bottom and 2nd from the top burner.

flame roll out

Anyway, this seems like a classic failed heat exchanger. The inducer fan seems to be working fine. Two burners are working properly, which would seem to indicate that the vent is fine. I also went up on the roof also and inspected the vent - looked fine, but has a difficult to remove cap on it, so can't see much

So I ordered a new heat exchanger and pulled the old one out today.

I've looked the old one over very carefully, but I can't find any damage. Tried stuffing rags in the outlets and hit it with the air compressor. Tried filling the tubes with water. No leak that I can see/hear/feel.

I'm reluctant to install the new part if I can't a defect in the old part. Any suggestions on what could cause this behavior if the heat exchanger is ok, inducer fan is working, vent seems fine?

Edit - took a close look at the burner tubes and gas jets. They all seem fine.

  • 1
    Additional troubleshooting: Set the fan mode to on. Hold a narrow strip of tissue paper or other lightweight thing in front of each burner opening. Do you detect any air flow? Leaving the fan on, turn off the gas supply and call for heat. When the inducer comes on use the tissue paper to check for draft in front of each burner. Are they all about the same? Also the burner tubes (the stamped sheet metal bits) can be cleaned; maybe disassemble those, clear out dust/spider webs/water droplets/etc, and reassemble.
    – Greg Hill
    Commented Apr 27 at 22:29
  • Thanks - to late to do the first suggestion since it's all apart now. But I took a close look at the burners and gas jets. They all look fine. No blockages. Commented Apr 28 at 0:55
  • 1
    Checking the gas jets was a good idea too. There exist "tip cleaners" used for torches that would do nicely to ream/clean the orifice. A small bit of debris, especially inside the header tube, wouldn't be visible from outside. It would be dislodged by a tip cleaner. A bit of wire, paperclip, straight pin, etc worked in and out through the orifice opening might work as well. Like the draft test, this is tough to test until unit is reassembled though. :-(
    – Greg Hill
    Commented Apr 29 at 14:25
  • Thanks for the suggestions. I put it back together yesterday and it works. The orifice on the jets is huge - much bigger then anything in my torch tip cleaner! If it looked like they needed it, I'd have probably used a bit out of the numbered drill index. Commented Apr 29 at 16:13

1 Answer 1


I decided to re-assemble things yesterday with the new heat exchanger, despite finding no problems with the old one.

And it works! Burner flames right where they belong.

It's frustrating to not know the root cause. I guess the one other possibility is that there was some fairly significant rust between the bottom corner of the heat exchanger and the manifold that holds the inducer fan. Condensation I guess. I suppose that could have been leaking and therefore not pulling enough air flow through the burner tubes.

But any leak would have been very small, and it's odd that it would just affect 2 of the 4 burners.

In any case, I cleaned it up with a wire wheel and sealed it with high temp silicone, and all appears good!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.