1

We have a KitchenAid dishwasher from 2015 that started getting standing water. Here’s what we’ve done:

  • cleaned the filter: didn’t work
  • replaced the pump: worked for a few days
  • replaced the pump again: worked but only on “pro” mode for about a month.
    • During this time we washed all our dishes 100% clean before popping them in. Ridiculous I know…
  • switched to pods

Now the dishwasher is clogged, again, and the repair man (second one now) says we need a new solenoid. I don't know anything other than what I’ve googled, but this doesn’t seem to make sense. The dishes get clean, the water always runs. When I press the “cancel” button, the pump whirs - but won’t drain.

Any other suggestions, or is it the solenoid? Do we just need to scrap this dishwasher?

1
  • Does your sink otherwise drain fine? Is the resulting standing water foil or clean?
    – Matthew
    Feb 6 at 4:24

1 Answer 1

1

It could be the drain attachment. Sometimes a pit or other hard item gets caught at the drain connection resulting in the symptoms you describe.

enter image description here

Image: https://howtofixit.net/dishwasher-not-draining/

Also posted as https://diy.stackexchange.com/a/218126/120147

2
  • This was checked and clear, as were the lines to the disposal. Feb 8 at 3:04
  • @Kangaroos777 you can feed the hose into a bucket and see what happens during draining. If the solenoid fails it could fail open or closed. If open, the water from the hose may flow back into the basin. If the hose makes a high-loop, make sure it siphons empty to the drain. If closed, nothing will come out and the pump will whizz idling.
    – P2000
    Feb 8 at 3:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.