I have a 90% efficient Lennox furnace, pictured below. Last night the heat stopped working. It actually had stopped working maybe a couple days ago too, but it fixed itself after a few minutes--I should've investigated then.


Anyway, here's the current behavior:

  • Thermostat calls for heat. LED indicator displays H (heat) and "A475" (the cfm).
  • Inducer motor starts going. LED indicator displays CAL (for calibration).
  • Inducer motor speeds up every few seconds, reaching its max after a while. Then it stops. Display shows E 228: Unable to perform successful pressure switch calibration.
  • Blower motor started while the inducer motor was going. Cold/ambient air starts flowing into the house, but the heater never ignites.
  • The same thing happens again after a few minutes, over and over again.

What I've done to troubleshoot so far:

  • I unplugged the drain hose from the flue vent (from top left going diagonally down). It had some water in it, which I drained.
  • There was also a bit of water pooled in the flue vent. I raised it a bit and saw the water drain out of the hole/nipple at the junction between the flue vent and the inducer motor (while hose was unplugged).
  • Since I also heard a bit of water in the inducer motor, I took it out and drained it too. There was just a bit of water, not much.
  • I thought this would do it (I had a similar failure last year and this was it), but it didn't.
  • I checked that there weren't any blockages in the air intake or the flue vent outside. I could feel quite a bit of exhaust coming out of the flue vent. I couldn't really check the intake very well since it's covered, but it seems to be circulating air alright.
  • Finally, I verified that the pressure switch is actually working properly. With a multimeter, I checked that when the inducer motor was off, the pressure switch was open (no continuity). As the inducer motor starts kicking in, the pressure switch would close (continuity). So that's working as expected.

That's about all I know how to do.

What else could I try? Some model info below.

codes model

  • 1
    You've solved your problem, but I had a similar problem with my Carrier, but a different solution. Mine was blowing air but the burners weren't firing. I determined that my colelctor box was full of condensate water and not draining. I drained it by disconnecting the tube to the pressure switch, and it worked for a day, then stopped again. I determined that the condensate trap was clogged. After blowing that out, all is well.
    – Huesmann
    Commented Feb 22 at 14:12

2 Answers 2


You've been very thorough. You could also verify that the small tube to the pressure switch is clear, but given the switch operates electrically, the tube probably is fine.

Many furnaces have two pressure switches, so check whether there may be another one you had overlooked.

A furnace controller typically checks the state of the pressure switch(es) before starting the inducer, then again a short time after starting the inducer, and expects to see the state of the switch change. This verifies that an unscrupulous person has not left the switch jumpered. If you hold a volt meter across the terminals of the switch you should see voltage (switch is open) and 0 volts (switch is closed) which demonstrates that the switch is working and also that it is connected to the controller.

The mention that the "inducer motor speeds up every few seconds, reaching its max after a while" sounds a little suspicious to me. This description makes me think that either the controller is pulsing the power to the inducer (weird?) or that the inducer comes up to speed slowly and maybe unevenly. Having 3 wires (plus ground) it might be a two-speed inducer. If you can verify it is a plain 120 volt AC motor perhaps you could try jumpering it directly to mains to observe its startup with the furnace control board out of the loop. I'd expect an inducer to reach full speed in under two seconds; if it takes longer that might indicate it is failing.

Digging a little deeper

SLP98UHV schematic diagram

Pictured above is a schematic diagram of the Lennox SLP98UHV furnace (excerpted from Lennox install & operation manual). I've highlighted the connections that go between the gas valve, safety sensors, and control board.

If you trace the wiring from pin 11 of the 12-pin connector it'll lead you to one flame rollout switch, another rollout switch, the high limit switch, and finally one terminal of the pressure switches. The rollout and limit switches should be closed, and if they are, you should find about 24 volts between the furnace chassis and one terminal of each pressure switch. The other terminal of each pressure switch should probably be around 0 volts until the inducer comes on. There are two pressure switches because the inducer can run at two speeds. The "low heat" switch should close and 24 volts-to-chassis would appear on its terminal when the inducer operates at low speed. Probably both pressure switches should close when the inducer operates at high speed.

There isn't much to say about the gas valve. Its C terminal should be connected to 24 volt common, aka furnace chassis, with very low resistance. The MV terminal should be energized with 24 volts-to-chassis at the point when the gas should turn on -- a second or two after the igniter begins to glow, typically.

I hope the schematic diagram helps you figure out where to place the volt meter leads to test the various components and what voltages should appear. If you reach the point of being confident that the safety switches are closed, inducer is working, pressure switches are working, a replacement control board is likely the next step. :-(

  • Thanks Greg. You're right that the inducer continuing to speed up, even after the pressure switch has closed seems fishy.
    – Rodrigo
    Commented Jan 22 at 16:49
  • FWIW, my pressure switch looks a bit different from the ones I've seen online or in YouTube videos. It has two disks (instead of one), and 5 tubes in total. Two tubes (one red, one black) go from the back chamber to the back disk (not pictured), two tubes go from the front disk to the gas valve (pictured), and one tube goes from the back disk to the front disk (pictured). I only checked continuity at the leads in the front disk (only place where I think it's connected). Not sure the switch could still be broken, or if these are actually two separate pressure switches?
    – Rodrigo
    Commented Jan 22 at 17:14
  • Well I had someone come in. For some reason, when they came in, the igniter was lighting up (I don't think it was lighting up before). But now the gas valve is not turning on, even after verifying that the board was sending a voltage to it... They want to charge me $600+ for the gas valve replacement, but I can find it online for $130 (I understand some markup on parts, but this is ridiculous).
    – Rodrigo
    Commented Jan 22 at 18:02
  • @Rodrigo When the igniter gets turned on it means the controller has passed the pressure switch verification/calibration step - having done nothing to resolve it, we might worry the E228 error could recur. The gas valve likely opens when 24 v AC is applied (check its label). Like the inducer, a person could test whether the valve operates by applying appropriate voltage directly to it (beware that gas will flow). If the components all work independently that's an indicator that the controller may be faulty.
    – Greg Hill
    Commented Jan 22 at 18:45
  • 1
    @Rodrigo There's 24 V ac between the R and C thermostat terminals. A few feet of two-conductor thermostat/bell/speaker/CAT5/whatever-small-gauge wire attached there will do the job. Touch those onto the two terminals of the valve. I don't know what to make of the small tubes connecting to the gas valve. Maybe the valve does have a built-in pressure switch. You might be able to search for its model number online and find some technical data about it.
    – Greg Hill
    Commented Jan 29 at 14:16

The solution to the problem was simply to replace the pressure switch. It's a dual pressure switch, with a high and low setting. Apparently these are "Costa Rica" switches that tend to fail often, and can be replaced with a model 14T64; the part sells on eBay for ~$50 and is a very easy replacement.

Now, the reason(s) why it was hard to diagnose are the following:

  • When I first tested the pressure switch, I only tested the front (low) one (by checking continuity and seeing that the switch closed), and that was working just fine. Two technicians also tested the switches and thought they were working correctly.
  • The gas valve in this furnace is connected to the pressure switch as well, presumably as a safety mechanism. So even though voltage was being sent to the valve, the valve was not letting any gas through because the back (high) pressure switch was not working. That's why even after replacing the valve with a new one, no gas was ever let through.
  • The technicians did test the back pressure switch at some point (though not with a manometer), and it seemed to behave correctly. But later on when I asked them to re-test with an actual manometer, it was shown to be faulty. By that point I had concluded that it must be the switch because nothing else made sense and my other furnace started to fail its pressure switch calibration.
  • At some point while debugging, the technician did replace the pressure switch on my broken furnace with my other (working) furnace's switch, and that didn't fix the problem. It's unclear why, but my guess is that the other pressure switch was also faulty. Indeed, the second furnace stopped working in a similar way a couple days after this test. Or maybe there was something else disconnected/turned off at the time in the broken furnace. It's very unfortunate because the result of this test sent us on a goose chase trying to look everywhere but further into the pressure switch.

Lastly, I think the reason why the pressure switches failed was moisture. The days in which both failed were particularly cold, and I think there was a lot of condensation making its way back from the exhaust vent and into the furnace (and drain). I think some moisture must've gotten into the switches and caused the malfunction.

Some learnings are:

  • Test the pressure switches thoroughly. A simple continuity test may not be enough. Use a manometer and test multiple times to ensure a reliable result.
  • Test both switches, not just one. This is kinda obvious in hindsight but at first I didn't even understand that there was a completely different switch behind the first one that was not working, even if the pressure switch calibration stage (which I believe requires both switches to close) was succeeding.
  • Related to the above, even if calibration succeeds, don't assume that it necessarily means that the switches are working as expected. Maybe with the pressure of the inducer motor the switch was closing, but maybe not at the required pressure.
  • When you've gone through and tested everything and nothing makes sense, go back to the very first thing and test again/more thoroughly.

Ugh.. this was a really unfortunate sequence of events. I was without heat for over 2 weeks and ended up paying $1250 in (basically wasted) labor and parts that weren't even broken (gas valve), when it all could've been solved with a $50 part that can be replaced in 5 mins. Hopefully this prevents someone else from going through the same.

  • 1
    Oh, one more thing that added to the confusion: the back pressure switch was making the click sound that these switches make when closing, yet it was failing to close properly. I think the technicians were hearing the sound and assuming proper functioning, which was a mistake too.
    – Rodrigo
    Commented Feb 21 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.