Water is contantly leaking so I want to open the lid of the tank and fix the leak. However, I can't open up the lid! Any ideas?

Picture 1: The water tank from above. The two buttons lifted out from their places. enter image description here

Picture 2: The lid pushed up as high as possible. A vertical plastic cylinder seems to be under the buttons.
enter image description here

Update after the comment of Wayfaring Stranger.
Picture 3: the lid lifted up as much as possible and slid aside as much as possible. The plastic structure under the buttons keeps the lid near its central position. enter image description here
Update after the answer from Michael Karas.
Sqeezing in a compact camera on the left then on the right (at the cost of some crepitating noise) I managed to make Picture 4 and 5 of the inside.
enter image description here enter image description here

  • 1
    These attach different ways depending on the manufacturer. I don't see a screw, and it looks like yours isn't attached by a cable that would allow you to lift the lid off. The next thing to try is unscrewing the outer chrome ring.
    – BMitch
    Commented Jun 23, 2013 at 11:00
  • @BMitch: Thanks for the idea (+1), but it does not turn. At least does not turn with a force that would risk breaking the plastic components.
    – winerd
    Commented Jun 23, 2013 at 11:39
  • 1
    I see you can get the front edge of the top up, and see all the way to the center. Look for some sort of clip or bracket along the back edge; against the wall. That's the bits you can't move. It may be a "pry front up and slide sideways" motion you need. Commented Jun 23, 2013 at 11:47
  • @WayfaringStranger: Thanks for the idea (+1). With the force I believed I could use without breaking the inside I was able lift the lid a centimeter and slide it aside two centimetres. It moves around, but the plastic structure under the buttons keeps the lid near its central position.
    – winerd
    Commented Jun 23, 2013 at 12:25
  • 1
    Have you tried pushing down on the plastic bits inside the chrome piece as you move the top? They may be what's preventing movement to the side. Commented Jun 23, 2013 at 13:08

3 Answers 3


There are multiple ways that this type if flush activator is connected to the lid.

With some you press down hard on the outer ring around the flush knobs and then turn it counter clockwise to remove the button assembly.

Some units may actually require this outer ring to turn around to unscrew from the inner part. Use of rubber gloves can help get a better grip on the ring.

On some others you take out the two buttons (which is often done by pressing one button down far enough so you can get under the other to pop it up) and then inside the opening under the buttons there will be a screw that you remove.

I have read that some others you lift the lid a small way, slide it forward a ways. Then feel along the back edge for a tab that you pull or push to release the lid.

After seeing your pictures I think that you should seriously consider that it may be time to think about how you would ever get this back together if you did manage to get it apart without any broken parts. I'd suggest shutting off the water line at the wall and then just yanking hard to take the lid off. Then retrofit your tank with a newer style mechanism that is built a lot more sane way.

Here are two more modern style mechanisms that could be considered. This first one simply lets the lid freely lift off.

enter image description here

This second style has a short connecting cable that joins the actuator to the flush mechanism so that the lid can be easily lifted up to service the inside of the tank.

enter image description here

  • Thanks. ❶ I tried turning the outer ring while pressing it hard down, too: after a half turn it stopped and further force would risk breaking it. ❷ I double checked and there is no screw accessible after removing the buttons (Picture 1) ❸ I carefully slid the lid forward as far as I could and squeezed my fingers in. I could reach the plastic cylinder in the middle, but found nothing to push or pull.
    – winerd
    Commented Jun 23, 2013 at 14:01

The solution was similar to one of the ways Michael Karas suggested in his accepted answer. I used a pliers wrench to grap the outer ring around the flush knobs and turn it counter clockwise. I used considerable force, risking that I would break some of the plastic parts. This was the solution.

I managed to open the lid this way and found something similar to Michael's second picture. Turning the ring should have unscrewed it near the top, but it got unlocked near the bottom instead. (I plan to add pictures.)

  • Put plumbers silicon grease on the threads on reassembly to make it easier to remove next time.
    – user13643
    Commented Jun 24, 2013 at 21:23

This a "Skipper 45" from SIAMP (a UK brand). You may see videos in their web site.

Pour water around the silver button to dissolve the minerals/salts stuck in the screw. Wear rubber gloves and turn the silver button anti-clockwise.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.