This is pretty strange: a few months ago I moved into a new apartment with a Fisher & Paykel refrigerator (freezer on top). It's a fairly basic unit, and until today it worked OK. This morning I opened the fridge door and the light did not come on; I figured the bulb had burned out. But then I opened the freezer door, and the fridge light turned on! There has never been any light in the freezer compartment as far as I remember, so this role reversal is quite troubling.

I did some poking around and discovered a magnetic sensor near the top of the fridge door. But it happens to be equidistant to the bottom of the freezer door! This is quite a strange design

enter image description here
From the second page of this PDF

With the small white plastic cover removed from the face between the doors, a cylindrical black magnetic reed switch is accessible. I pulled it out--it has about two inches of extra wiring, and played around with it. I tried turning it about its main axis to see if its orientation matters--that didn't change much.

It simply seems that the sensor is far too sensitive, and that the freezer door seal is more than enough to trip it, even as the door is still 1-2 inches from fully closed. It is hard to believe how this system ever worked.

Calling a repairman is likely to be expensive and the landlord will probably try to make me pay for it (I live outside the US, so don't be too surprised). Entirely disabling the switch seems improper, not only because the light would stay on but because this fridge seems to change its fan behavior depending on the door open/close state. I briefly experimented with taping the sensor to a location much lower on the face of the unit, far enough from the freezer door to avoid it tripping when only the freezer is closed. But it's hard to get the fridge door to trip the sensor this way--the light seems to just stay on, as if the sensor were designed to do the opposite job it is meant to do.

  • The fridge reed switch may be nearing its life expectancy or # of duty cycles. Also the magnet in the freezer door may have shifted, can you identity where the magnet is and see if you can raise it or possibly even remove it and replace it with a weaker magnet to just trip the one sensor.
    – Jason
    Commented Jun 21, 2013 at 14:20
  • 1
    Are you sure there is not another switch for the fridge door? This one really looks intended for the freezer door in order to shut down the system when the door is opened. The light going on is either a flaw in the control board or an intentional "feature" to save manufacturing costs. If the separate fridge switch were working, no one would ever notice the light going on in the other compartment.
    – bcworkz
    Commented Jun 21, 2013 at 19:29
  • @bcworkz: wow, you're right! I looked again and sure enough, there is another one of these switches at the very bottom, below the fridge door. What's even more interesting: leaving the fridge door open made the door-open alarm go off, so both door switches are clearly working! Now the question is why the fridge light comes on when the freezer door switch is activated, but not when the fridge door switch is activated. That part is still mysterious to me. What do you think about that? Thank you! Commented Jun 22, 2013 at 0:33

2 Answers 2


Well, the problem is solved, thanks to a great insight from @bcworkz in the comments.

It turned out that there was another magnetic switch at the very bottom, below the fridge door, and this is what is meant to trigger the light. For reasons unknown, the light had decided to activate only by the freezer door switch, even after I unplugged the whole unit and plugged it back in. However, @bcworkz's comment about the control board having a problem got me thinking, so I started pressing buttons on the control panel at the back of the fridge. I pressed the left-hand button that selects fridge or freezer when making temperature adjustments. And lo, the lamp turned on immediately!

So I don't know why this whole thing happened, and pressing the button again doesn't make it broken again, but it's behind us now, presumably some strange bug in the embedded system logic.

  • 1
    That's crazy! The best explanation I can think of is the controller memory became corrupted for some reason and toggling the settings back and forth refreshed the bad bits so everything works fine again. Only a wild guess though, I'm pleased you were able to resolve it, even if we don't know why.
    – bcworkz
    Commented Jun 22, 2013 at 18:46

The button fixed it!! Yay

Same problem, and I can second that resolution. Took me a few weeks to google the problem, bit lazy about it. But was very annoying not having that light I can tell you. And came across this. Pushed the left button thats at the back there a few times and it came on. Been working ever since. Thanks for the leg work. :) :)

  • That should've been a comment to the other answer.
    – Astrogator
    Commented May 19, 2020 at 21:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.