4

I have a whirlpool gas range bought from Costco 4 years ago (WEG745H0FS). Of late, one burner does not light up even though the sparks appear on the burner. If I blow air on the burner, the flame does light up (meaning the igniter does produce sparks that would ignite the flame if enough gas came to it).

I have tried to clean the burner and grates immensely. I have also tried the brush the igniter with a brass brush. I have also taken a wire and tried to clean the hole from which gas comes out. None of these have resolved the issue for me.

Any idea what I can do?

Photo of burner: enter image description here

7
  • Can you clarify/expand on this "If I blow air on the burner, the flame does light up." Also could you post a photo of the burner?
    – Armand
    Commented Feb 6, 2023 at 3:49
  • I read somewhere that blowing air on the burner (which probably leads to chances of gas moving around to the igniter) can lead to better chances of ignition. Of course its not something I want to use to light it up but I wanted to check whether the igniter will ignite gas at all. Here are pics: imgur.io/a/QKDf3UF Commented Feb 6, 2023 at 5:14
  • Looks like the burners need a plate-like "cap" to work properly -- see the previous question I linked.
    – Armand
    Commented Feb 6, 2023 at 5:52
  • 1
    @Armand - as the OP has had the stove 4 years, let's assume they're perfectly aware the cap needs to be on to work, but we're being shown detail which would be hidden it it were in place.
    – Tetsujin
    Commented Feb 6, 2023 at 16:00
  • @CaptainJacksparrow Could you clarify if the non-lighting issue is with your burner caps on as well, and if Tetsujin's suggestions in their answer work?
    – Armand
    Commented Feb 6, 2023 at 17:47

2 Answers 2

5

If it's sparking but not lighting & works if you blow it [& presumably if you were to light it with a match] then the spark is probably jumping the wrong way.

If that's your own metal foil & not integral, first thing would be to get rid of it, or at least get it out of the way of the igniter.
Secondly [this always works on mine] put the burner cap back on then pressing down with not too much force, scrub it back & forth - a twisting motion - to scrub the underside against the base, removing any residue or rust.

It took me quite some time to realise that the spark isn't meant to jump to the main body of the burner as we can see it in your image, but upwards to the cap… right through the gas-flow.

4
  • That's interesting. I'll try out the second method. I've already tried to remove the foil but hasn't helped Commented Feb 7, 2023 at 7:21
  • Basically, it's just a quick & relatively efficient way of scrubbing the underside of the cap. Mine get rusty all the time which stops them working. A good wire-brushing every so often gets them clean, but this 'twisty-scrub' action can sometimes be all it needs to re-seat them & make better electrical connection.
    – Tetsujin
    Commented Feb 7, 2023 at 7:26
  • Can you explain more on "wire brushing" Commented Feb 12, 2023 at 5:57
  • Not sure what more I can add… brush with a wire brush;) Brass tends to leave a black residue, steel is harder, but 'cleaner'.
    – Tetsujin
    Commented Feb 12, 2023 at 10:48
4

I see from the photo that the spark point insulator is coated with burnt-on carbon. This is a conductor, and the spark is jumping sideways from the carbon to the body of the burner, instead of straight up to the cap.

Scour the black coating from the spark point until you see only shiny1 white insulator.

Also make sure that the cap, burner, and any other conducting metal parts are shiny-clean where they touch each other.


  1. It's okay if it becomes a little less than factory-shiny from your scouring.
2
  • I've brushed the igniter many times with a brass brush that ended up taking some of the white coating off. What do you recommend to use to scrape off the black coating? Commented Feb 7, 2023 at 7:23
  • Actually, if you used a brass brush, the 'black' could be brass. I tend to use steel on mine - doesn't seem to hurt them.
    – Tetsujin
    Commented Feb 7, 2023 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.