0

Part 1: Old Whirpool gas stove mystically stops making spark when I put the cover on

Well, few days ago I posted a question (see the link above) where I had a problem with getting spark when I put the lid on. After I solved the problem it started to work flawlessly: spark was always there and thermocouples needed not more than ~3 seconds to start sustaining the gas flow. Everything was alright.

Today, without any special event preceding this I discovered that 3 burners (except bottom right one, which worked just fine) don't sustain the gas flow after you stop pressing black button anymore (even though every burner worked yesterday), doesn't matter many times you try or how long do you press the gas button. Spark & ignition are working just fine this time, no problems with them at all.

I decided to take the lid off one more time, briefly looked through all the thermocouples (I cleaned all of them as much as I could in the previous part), maybe touched few wires, but in general didn't do anything significant. Then I had the following consequence of actions:

  1. I put the small black lids on the burners to test the thermocouples once again without the stove lid - and surprise-surprise: everything worked just perfect.
  2. I took off the small black lids from the burners and put the big gas stove lid again and the small burner lids again and tested everything once again - everything is working just fine.
  3. I screwed all the screws back, and tested everything once again - this time only two upper burners were sustaining fire, the bottom two ignited well but didn't sustain the gas flow.
  4. I disassembled the lid once again and put the black burner lids to test all the burners again, multiple times - every burner worked well and sustained the gas flow well after igniting.
  5. I have put the big stove lid again (without screwing the screws) - now I tested the bottom left burner and it worked, then I tested the bottom right burner - and it didn't work. And then I tested the bottom left burner once again and it stopped working.

P.S. Every time I write "it worked" or "burner worked" I mean that the burner sustains fire after you stop pushing the gas button on the right. The gas is there, the spark is there, the ignition is happening. Just the gas stops flowing as I take my hand off the button.

Photos: Photo 1 Photo 2 Photo 3 Photo 4

2
  • Possible with an older stove some parts might be worn out and not holding as they should. Some tubes might have dirt in them.
    – crip659
    Nov 29, 2022 at 14:11
  • Thermocouples run down electrical wire, just heat-proof wire - wire connections may be failing, or shorting.
    – Tetsujin
    Nov 29, 2022 at 19:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.