3

I’ve read several similar posts and answers but I think my faucet may be a bit different. I have a hidden / recessed aerator but there are no notches for any tools to fit to unscrew it. However I’m able to twist the aerator with my fingers but it never seems to get any looser or tighter, it just keeps spinning.

I tried taking a wrench to the faucet spout (first two photos) but nothing budged. Any suggestions for how I could remove the aerator for cleaning would be much appreciated! Photos attached. Thanks!

enter image description here enter image description here

enter image description here

0

1 Answer 1

5

The bottom ring( the one with the stains) shown in the first picture, probably unscrews.

Try dipping the end in some vinegar for a few minutes first.

Would try by wrapping cloth or rubber around it and using pliers/small pipe wrench to unscrew.

1
  • I tried taking a wrench to that part last night and it didn’t budge. After leaving it in cleaning vinegar overnight it worked! You were right, that part did unscrew. Many thanks!!
    – Pete
    Sep 25, 2022 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.