2

In the past I've replaced a bunch of these types of things: enter image description here

with these:

enter image description here

Today in a different house I went to do the same thing (to change from bulbs to integrated recessed LED), but I could not figure out how to remove the existing "can". I put that in quotes because it is very different from the ones I have worked with in past - it is all plastic. This is what it looks like (zoomed out for context):

enter image description here

and closer up: enter image description here

I've tried pulling down pretty hard on the trim ring but it doesn't budge. Does anyone know what these things are called and how to remove them?

--- Edit --- Here's a closer picture of what looks like a tab, but try as I might to press it it doesn't seem to move:

enter image description here

4
  • it looks like it is artached to the bulb socket
    – jsotola
    Commented Jun 19, 2022 at 1:11
  • @jsotola it sure does! Those clips do seem to move a bit when I push them. So you're thinking squeeze those hard and then the whole enclosure should pull down out of the ceiling leaving only the socket? I'm hesitant to do anything that includes "hard" until someone is confident that that's the right action haha. Commented Jun 19, 2022 at 1:20
  • That rivet is probably the other end of that clip. Between that clip and the behind side of the housing, there's probably 'tab b'. You probably have to push that end of the clip so far in that there's room for tab-b to slip out of it.... at the same time on both sides, and not being able to see anything. Good times. Could try detaching the socket; might be hung just from that. But if you lose it in the ceiling, you're committed to getting it open.
    – Mazura
    Commented Jun 19, 2022 at 1:38
  • @DavidDoria I'm hesitant to do anything that includes "hard" until someone is confident that that's the right action ... just because someone is confident, it does not make the action correct ... turn off power ... squeeze the lever at the socket and gently wiggle the socket to see if it is attached to something else or if it is clipped only to the can
    – jsotola
    Commented Jun 19, 2022 at 2:31

2 Answers 2

3

Ok, I figured it out. It's a case of Occam's razor... The trim was simply "glued" to the ceiling paint. I cut around it with a box cutter and then was able to pull it down without much trouble. Here it is: enter image description here

Then I used the clips at the top to pop out the socket. Finally I could screw in the "pig tail" of the LED light to the socket and push the whole mess of wires up into the can and use the torsion springs to attach the LED fixture to the can as usual.

0

Great Phots.

To me this slot looks like sprig loaded latch.

It even has rounded corner for better function

if those slots can be pushed in (with screw driver), try to see if they go far enough beyond the thickness of the housing. No force need to pull out the lamp.

You can even use a toothpick to prevent them snapping in while you work on the other side. latch

There should be 2 of them one on each side.

You might also have spring loaded latch inside on the top

1
  • try turning the can
    – jsotola
    Commented Jun 19, 2022 at 2:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.