1

I have an AEG dishwasher (fsb42607z) that will not start.

This started a day ago. I set a program and close the door. About 2min later the door just opens. No sounds of even trying to pull water, drain, nothing. Just opens. When it does there is no sign of the lights flashing or anything. Just looks exactly as it did when I set the program

I have checked water pressure and that looks good. Checked pipes for kinks, nothing there. Stuck a snake camera down the sink hole to check for a blockage, clean as you like.

Booked an engineer but they won't arrive for another 2 weeks. AEG is starting to feel like a bad brand at this point. They didn't even bother troubleshooting with me. The manual does not state this scenario.

Any idea would be awesome. Cannot open the machine for warranty reasons. I just don't want to wait two weeks only to be told it was something silly.

6
  • Tried a forced empty pump cycle? often there is a button combination to do that. Or is there a reset combination?
    – Solar Mike
    Commented Feb 22, 2022 at 10:36
  • One problem with one particular machine doesn't mean the company's entire product line is bad, nor does a delay in obtaining service - every company is having a hard time with employees right now. It may be that it'll be another 2 or more weeks to get repair parts because the places that make the parts are running behind, too.
    – FreeMan
    Commented Feb 22, 2022 at 12:57
  • The first thing a repair person will check is to make sure the float/switch in the bottom of the machine is not jammed on a fork or something. It is there to measure the water level. Commented Feb 22, 2022 at 15:39
  • @FreeMan I have had the machine less than a year. I spent a lot of money on it. I think I can be allowed some frustration. If Aeg had explained the reason for the delay I would be more understanding. When I explained the issue and they told me 2weeks wait my first question was why so long. The lady said it just is. No explanation. So, I stand by my frustration, it is entirely justified. Commented Feb 25, 2022 at 9:43
  • @SolarMike Tried to force the drain cycle and nothing happened. No sound, nothing. Maybe the flood prevention switch Steve Wellens just mentioned could be the reason. Won't know till the engineer arrives. Thanks for trying guys Commented Feb 25, 2022 at 9:45

1 Answer 1

4

In case someone else comes across this. There was no issue with the machine, it had entered demo mode.

To deactivate it

press ECO + Auto for 5seconds

This just goes to show that AEG should have just debugged with me on the call. If they had done so we would not have had to wait 2 weeks and no engineer would have been called. It is also not in the manual. Multiple failures here AEG.

1
  • 1
    Wow... What a pain! Thanks for coming back to document the solution.
    – FreeMan
    Commented Mar 7, 2022 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.