0

Furnace runs for a few minutes, then limit switch trips when it reaches 32.5 celsius. System worked before. No changes.

  • Same happens without filter
  • Vents are not blocked
  • Cleaned heat exchanger
  • Tested a second limit switch, same result
  • Blower motor cleaned. Not loose. Running (slowly?)

I've ordered a replacement motor capacitor, coming in a week.

Also, I'm able to restart system by letting blower cool down, resetting switch, and power cycling. Flames don't seem to be blowing back.

I'm running out of ideas.

Could the capacitor be the culprit?

5
  • 1
    Which limit switch? Heat exchanger temperature limit, or something else?
    – Greg Hill
    Oct 22, 2021 at 0:12
  • 1
    What make/model is said furnace? Oct 22, 2021 at 1:45
  • Flame roll out switch. It’s a reset-able switch located beside the burner area, that trips at 32.5 degrees Celsius. Oct 23, 2021 at 3:17
  • The make of the furnace is Bryant. I’m not sure where to find the model. Oct 23, 2021 at 3:19
  • New information. I opened up a (duct side) cover around 8” in diameter between the heat exchanger and the AC coil. Problem does not happen, as there is more airflow, which is what I’m trying to prove. Does this mean my blower is running slow??? Oct 27, 2021 at 1:05

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.