I am trying to disassemble a faucet to replace its cartridge. However, after taking out a metal button, there is no way to further disassemble anything.

I could not see into the hole because of the angle, so I just tried different hex drive but I could not hold onto anything at all in the hole.

Am I doing it wrong trying to disassemble it with a hex drive?

enter image description here

[Edit] Here are pictures taken with a mirror and a flashlight. They are not of the best quality. Can anyone identify a nut or screw or anything?

enter image description here enter image description here enter image description here enter image description here

  • 2
    Have you tried both standard and metric Allen wrenches in ALL sizes? It can be very difficult to get it lined up correctly. Sometimes i have seen them attached with a very small slotted screw. See if you can use a phone camera to take photo with a flash.
    – Alaska Man
    Mar 29, 2021 at 22:28
  • I tried all Allen wrenches that I currently have - that is around 20 of them. I think I am going to try to see into the hole with a mirror and a flashlight following JACK's suggestion.
    – sofname
    Mar 29, 2021 at 22:51

3 Answers 3


You need to get a small mirror and bright flashlight and reflect the light into that hole so you can see what you're dealing with. Just about every screw in those handles needs an Allen wrench to remove it. It could be SAE or metric.

Once you get that handle off, you have to loosen the chrome collar at the seam you can see in your photo. A strap wrench or leather belt (Thanks Ed) works so you don't damage the surface.

These faucets are tricky so don't get too discouraged if things don't go right the first time.

  • Sure it is tricky. I'll try the method of mirror and flashlight.
    – sofname
    Mar 29, 2021 at 22:44
  • 1
    Finally fitted in with a 3/32 hex key, and the handle is off. I'm excited. The next step is figuring out the chrome colar at the seam part...
    – sofname
    Mar 31, 2021 at 5:01

Sometimes the Allen screw in there is corroded or stripped. In this case, you may need to drill it and use a screw extractor to remove it. I have done this many time with these type of faucets.

  • Whoa! Never imagined drilling it. I may do that if I run out of options.
    – sofname
    Mar 30, 2021 at 22:02
  • It’s not a hard procedure; easier than you think. A small drill bit followed by a small spiral screw extractor.
    – Falomany
    Mar 30, 2021 at 23:25
  • Thanks. I learned about spiral screw extractors - the knowledge will be useful for later.
    – sofname
    Mar 31, 2021 at 2:00

For whom may run into the same problem:

  1. Remove the metal button. Before this, block your sink to prevent losing the button or other things in the sink.

  2. See into the hole with a mirror and a BRIGHT flashlight. I tried different flashlights, eventually a really bright one helped.

  3. Loosen up the screw in the hole and remove the handle. Try ALL sizes of hex keys, both SAE and metric. Most likely a key with a smaller size will fit in. In my case, it is a 3/32 one. You don't need to take off the screw. You only need to loosen it up.

  4. According to lots of online cases you need to remove the chrome collar, the decorative cover, before you can remove a retainer to take out the catridge. In my case, I don't need to. In fact, I should not have tried to but I did, and left some pipe wrench teeth marks on the cover.

  5. According to lots of online cases you need to replace the catridge. In my case, I just tighten the retainer nut and fixed the leak. Of course, I took this chance and cleared up Calclum deposits around the catridge with white vinegar.

Most importantly, as JACK says, don't get discouraged if things don't go right the first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.