0

Steps to reproduce:

  1. Plug in dehumidifier. The green LED goes on.

  2. Press the power button on the control panel (lower free hanging PCB in picture).

  3. The fan starts running. The compressor doesn’t turn on as far as I can tell. After about five seconds the dehumidifier shuts off with a click sound, possibly from a relay. Even the green LED goes off, which – I believe – should remain on even when the machine is in standby.

    Occasionally there is a bunch of lights blinking, sometimes all of them. Normally though, it just shuts off.

  4. Now it’s dead. Pressing the power button as in step 2 won’t revive it. What needs to be done: Remove the power plug and reinsert it.

Annotated photo of open dehumidifier Whirlpool SS226, 220–240Vac, 50 Hz

I have checked all capacitors, all sensors, and the three big relays. They all seem to be OK. The compressor turns on when I bridge the respective relay. Furthermore, I’ve tried to no avail:

  • Replace the starter capacitor with a spare part.

  • Bridge the sensors with suitable resistors.

  • Disconnect the compressor, the ionizer, the fan.

What could be the issue? What else can I try?

I bought the dehumidifier used in Hong Kong. When I arrived to pick it up, the seller – an individual who is moving out of his apartment – said that he just realized that it doesn’t work anymore. In fact he had two of them, both broken. Apparently they still worked last summer. I nevertheless took one of them for a few bucks. If I cannot get it running, I’ll dump it at the recycling center around the corner.

I did search extensively for a service manual online, but couldn’t find it. The included user manual does not cover my error condition.

Update: After checking the relays, the status LED blinks green, and the dehumidifier cannot be turned on anymore. It’s possible that I inadvertently damaged the circuit when I applied voltage to the relay coils using a bench power supply. Hopefully it’s something else.

3
  • 1
    Maybe this is what the seller meant by "broken"? Have you searched the internet for instruction/repair manuals for this make/model? Since you haven't provided that info to us in your otherwise rather complete question, that part's on you. Oh, and do you have a question or are you just giving a status report? We really need a question to answer... – FreeMan Jan 29 at 13:35
  • Have you tried checking the winding resistance on the compressor motor windings? – ThreePhaseEel Jan 30 at 3:28
  • @ThreePhaseEel I removed the cap on top of the compressor. The external compressor protector has a resistance of 1Ω, which apparently is good. Then there are three wires going into the top, one red and two white. The difference between each two of them is between is between 20Ω and 60Ω. The compressor itself looks like it cannot be opened. Is there anything else that I can check? I am happy to update my question with more details. – feklee Feb 3 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.