I have a Dettson Hydra20. Two days ago we woke up to 17C inside the house instead of the 21C set on the thermostat. The water temp on the boiler was at 40C and not moving. I also have a gas fired boiler (dual energy setup), I switched to gas and the water temp quickly went up to 80C.

Today I did some troubleshooting on the electric boiler. I changed a relay that I think was faulty (I wasn't hearing clicking, though in retrospect, I should have checked voltage at the heating elements to be sure). After that, I ran the electric boiler again, water temp got up to about 55C after thirty minutes or so. The problem is that the water temperature is set for 75C using the set screw. Even after an hour, it never gets past 60C. Pressure stays at around 18psi. From what I recall, before it was getting up to 75C and about 25psi. The radiators seemed hotter before, though I don't have temperature readings to prove it.

I tried rolling back the set screw water temperature control and the boiler turned off as expected. Rolling it back up turned the boiler back on. So this seems to be working normally.

All four heating elements check for continuity and do not have shorts (touching terminal and other metal on the element with meter). Each shows ~12 Ohms resistance and when running, ~240V.

Is it possible that I have a bad or under-performing element? Anything else I should check? Thanks a lot!

  • did you check the resistance or continuity for your thermostat? is it working as should be? Commented Dec 28, 2020 at 4:18

1 Answer 1


Unlikely an "under-performing element", they usually either work or don't work.

2 things come to mind: 1) The flow rate thru the electric boiler is just too great to get the water up to temp, or 2) You have a control problem. Did you check to see that all the elements get power? Is there any staging involved? Your thought that it might have been a bad relay was a good one and it sounds like it might have addressed at least part of your problem.

How closely were you monitoring the system before the problem? Maybe what you are observing now is how it was operating before, but just didn't know it.

  • The boiler is working normally now, either it was/is an intermittent problem that went away or I wasn't waiting long enough for it to get up to temp when I was observing it. Things I did before it started working again: Checked the voltage on each of the four elements on startup (they turn on one at a time. Voltage was normal). Bled a tiny amount of air from the bleed valve. Checked the drain valve to make sure water was running clear (i.e. no sludge). Turned the temperature control up to the max just to see if the water would get past 60C (It did). Waited longer (took about 2 hours).
    – Michael C
    Commented Jan 4, 2021 at 14:34
  • @MichaelC Thank you for the follow-up. Many times people solve their problems and just don't bother to post again and let us know what happened. Commented Jan 4, 2021 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.