The gas heater pilot light has been out for a couple of days, and I believe there is a safety mechanism that detects this, and shuts off the gas. Now, when I move the slider to the pilot light position and press the valve button, I don't hear any gas coming out. Is there anything I need to do to


You may not be able to hear the gas for the pilot light, it doesn't take much. Get a long match or lighter that can reach the pilot light and try to ignite it while holding down the valve button. That button overrides the thermocouple that will automatically shutoff the gas when it cools down. You need to hold the button long enough to heat the thermocouple back up while the flame is burning (30-60 seconds is usually good). Once the flame stays lit without holding the button, you can close the water heater back up and adjust the tank thermostat back to your normal temperature.

  • Thanks, I tried that. I held the button down for up to two minutes, while holding a lighter right up against the nozzle. The pilot never lit up. Checked the gas shutoff lever, it's in the open position. The fact that the pilot light went out in the first place makes me suspect there may be something wrong with the thermal coupling. I've seen gas technicians test the thermal coupling using a volt meter. I'll do some research, and try that next. – alekop Dec 3 '12 at 18:10
  • @alekop Something is broken, but I'm guessing that it isn't the thermocouple in this case. If that was faulty, the pilot light would light but go out when you released the button. You may have a blockage in the gas line or maybe a flue temperature sensor has gone bad. – BMitch Dec 3 '12 at 18:32
  • Yup, you were right! It was a blocked nozzle. The gas technician removed the pilot light nozzle, and when he pressed the button gas started flowing. He cleared it out by blowing on it, put it back, and that fixed it. – alekop Dec 7 '12 at 19:40
  • Isn't it depressing when you hire someone to fix a problem like this, and their solution is to blow on it? Thanks for the follow up @alekop. – BMitch Dec 7 '12 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.