0

I have couple of sockets I added through my electrician sometimes back. Now when I plug microwave or coffee maker, it plug would just not go in!

I don’t want to put extraordinary force for fear of breaking it or I should just force it in?

Is it because this is new, not used? How can I make the plug go in without breaking it?

enter image description here

  • 1
    I can’t tell from the photo but are these tamper resistant receptacles? If you look in the slots there is usually a plastic piece blocking the opening on tamper resistant receptacles. I find wiggling the plug back forth with a light force will usually release the “doors” and allow the plug to go in. I have also found on some brands a slight circular motion helps I can’t remember if it was CW or CCW motion that worked. Give that a try and let us know. – Ed Beal Oct 28 '20 at 13:07
6

Those don't look like tamper-resistant outlets to me.

New sockets are often just stiff. That's how it is.

Mind you, the "loosy goosey" sockets you are accustomed to, are actually a fire hazard. When contact is poor, a tiny gap will form, and electricity will simply jump across the gap. This action is called "arcing" and makes a LOT of heat and soot, and that tends to make the arcing worse and worse, and it's a death spiral of destruction until you have a fire in the outlet.

So stiff outlets == good. Plug it in totally square (in case it's a tamper-resistant) and push like you mean it. Power plug blades are quite durable. Honestly my biggest problem is breaking off ground pins from having pulled sideways on the cord.

  • Thanks I was able to force plug in both of the sockets. I was always trying to push in perpendicular but this time just maximizing the force and keeping it there worked. I was earlier deliberating to do high intensity impulse force at one shot but I think that's not good idea, could break the thing. Just use maximum soft force if anyone is in the same situation. – zar Oct 29 '20 at 8:35
4

The picture is not in focus enough to read, but presumably they are "tamper resistant" as that has been code for a while.

Those can be fussy, and require pushing both flat prongs in straight, so they enter at the same time. The mechanism is intended to protect against (usually children, but not always) pushing a conductive object (not a plug) into one slot and getting electrocuted.

If you start a little bit off, they jam and won't go, so don't force it, back off and try a slightly different angle until the plug starts to go in.

  • a small jiggle as you insert may also help move the shutters out of the way – ratchet freak Oct 28 '20 at 13:37
  • 2
    Frankly, when zoomed in, that doesn't appear to be TR - usually you can see the little doors in the slots, and I see no signs of them. – FreeMan Oct 28 '20 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.