9

After flushing, my toilet doesn't sense that it needs to refill. See the below image. If I so much as gently touch the gray piece, the toilet starts to refill. Any easy fixes?

enter image description here

  • I too wd-40'd it. Big success, but later read this answer column and it says no oil based – Betty Mar 11 at 22:13
4

I've dealt with the same problem with the same float. In my case it was grit and gunk that got between the float and the cylinder that was keeping it from sliding easily. All I did was turn the water off and clean it up with kitchen/bathroom cleaner and a rag. You clean the top area, then slide the float up, then clean underneath. Chances are you'll feel the binding when you slide it up and down, it will feel like it's catching on individual particles. Once it is clean enough you won't feel that binding anymore.

  • 1
    I did this as the first step. While it improved the situation, it didn't solve it 100%. I also tried BMitch's advice above but that didn't work either. So I just bought a new one. But at a minimum your solution is worth a shot before buying a new valve since its so simple. – maxedison Dec 10 '12 at 17:28
  • @maxedison, thanks for that update, it's good to hear what really happened. Sorry it didn't work for you, sometimes things just can't be fixed. – GdD Dec 10 '12 at 19:51
  • Say, what if a bit of water were to find its way inside the float? Then it would lose some buyoancy and not rise as high as before or push the valve with as much force. Any heavier-than-water gunk and calcification sticking to the float itself will weigh it down, too. – Kaz Apr 15 '14 at 18:56
  • Some adjustment may have to be made. It could be that the float is floating freely and correctly relative to the water level, but the level is rising high enough to leak into the overflow pipe without the valve being closed. Maybe something can be adjusted to close the valve. Else the valve is simply leaky. Maybe there is a simple way to extend the height of the overflow pipe. If you add a quarter inch to the height of the pipe (say with a ring of some sort of waterproof tape), it will raise the water level, and generate additional pressure on the float. – Kaz Apr 15 '14 at 19:00
  • Kaz, the problem is that the float is sticking in the "up" position, thus preventing the valve from opening and refilling the tank, not that it is too heavy or not buoyant enough. – Andrew P. Apr 5 '16 at 20:45
8

Try to clean the valve by following these steps:

  • Shutoff the water to the toilet.
  • Flush the toilet to empty the tank (doesn't have to be completely empty, but you want some working space).
  • Open the valve by lifting the float to the top position, pressing down on the black plastic cap that covers the valve, and giving it a 1/8 to 1/4 turn. You should then be able to lift the cap directly off.
  • Clean sediment or other buildup off any small components of the valve, and if anything is easily detached, remove it temporarily for the next step. Be sure to check inside of the cap where the lever is attached.
  • While the cap is off, place a cup over the top of the valve and open the water supply for a few short bursts. The cup prevents a small geyser from appearing in your bathroom and the water will drain into the toilet tank (this is why you flushed it earlier). This process will clear any sediment out of the valve and supply line, including any sediment that may break free from the toilet shutoff valve.
  • With the water shutoff again, reassemble the valve, and attach it in the reverse process (lifting the lever on the float allows you to turn the cap with a little downward pressure on the cap).
  • Cross your fingers and turn the water supply back on.
  • 2
    That was it! I thought the floater was getting stuck on the shaft, but the problem was actually inside the valve itself. This is a good video explaining how to remove the cap: youtube.com/watch?v=J3RTqOlgP0s – Lawrence Kesteloot Jul 17 '14 at 23:34
3

After reading here and learning how to remove the top part with the arm I found that my arm was binding sometimes and now allowing the float to drop when flushed. I soaked the top assembly in some CLR in hopes of removing calcium or water deposits, rinsed it off and reassembled and for now seems to be working well. Thanks.

2

I just had this problem. I did what BMitch described in his answer, and found the video linked by Lawrence Kesteloot to be very helpful just to understand what we're talking about. I found that in my case, after removing the cap off of the valve, the float was sliding up and down on the shaft very easily, so that didn't seem to be the problem. However, on the underside of the cap was a rubber seal that was causing lots of resistance. It was easy to pull off this seal and confirm that the arm went up and down without resistance when the seal wasn't there.

Here is what the cap and arm look like when removed.

picture of the cap

On the underside of the cap, I saw the black rubber seal with a pin that slides through it as the arm goes up and down.

enter image description here

The black rubber seal was easy to remove, and I found that the arm moved without resistance once this seal was off.

enter image description here

I tried cleaning the pin and seal, but I still found resistance when moving the arm. I decided to apply some lubricant. I didn't try searching very hard, but this quickly found link suggests it would be a bad idea to use a petroleum-based lubricant. I decided to use some medical lubricant (generic version of KY jelly) I had on hand. I don't know if this is a good long-term solution, and I suppose silicone lubricant from the hardware store would be a better idea. So far it seems to have worked!

  • The type of lubricant that you used won't hurt the rubber top seal, but it is wholly unsuitable for this application, as K-Y jelly and other similar "surgical lubricants" are water soluble and will be rinsed off the seal within a short time after water starts flowing through the valve. If it worked for you, it may have because you cleaned out some contaminants while applying lubricant. A better solution is to install a new top seal; they're inexpensive and readily available in hardware stores. – Andrew P. Apr 4 '16 at 10:54
  • 1
    I won't dispute that buying a new seal would be better. However, I will say that my approach solved the problem for a few months, and then the arm started sticking again. I then applied some silicone lubricant, which seems to have kept it working for about a year now. – Tony Pulokas Apr 7 '16 at 18:50
  • I used dish soap to lubricate the gasket. Still working after 10 flushes, but I'm not optimistic for the long term. – ntc2 Jul 21 '16 at 5:32
  • 1
    UPDATE: the dish-soap-lubricated gasket started seizing up again yesterday. So, the dish soap worked from July 21 to August 6, about two weeks :P – ntc2 Aug 7 '16 at 18:31
  • 1
    UPDATE: I ended up going to a local plumbing supply store and buying a "ballcock repair kit for Fluidmaster ballcock top assembly cap 400A (part 04-7173)" manufactured by LASCO for $8. This is the entire cap and arm assembly pictured above in the answer, and includes the washer. Online I see you can buy just the washer for a couple of dollars. – ntc2 Aug 7 '16 at 22:31
1

Sometimes, with a fluidmaster, the secondary chain can be too loose to flip the "fork" at the bottom of the floater....get rid of all the slack ...it will flip it and loosen the floater

1

I disassembled the unit to remove the float from the shaft. It did feel slightly gritty, but even after rinsing both thoroughly they were still binding. I decided to rub a candle on the shaft to coat it with wax. The candle wax is not water soluble, will not degrade the plastic, and did the trick for me.

0

I had the same problem which caused a lot of frustration. I want to share a simple solution that worked for me. All you have to do is take a small plastic bag (small enough to fit your tank without impeding the other parts of flush mechanism). Fill the plastic bag with a little water (maybe 1/4 cup) + some volume of air, then tie up the bag. So the bag will be like a balloon with water and air inside; tie the plastic balloon on your float. The plastic balloon will float together with your float because of the air. but when the toilet is flushed, the water weight of the balloon will pull your float down, thus triggering the water filling action. This might take some trial and error with regards to the size of the bag and water to air ratio but this worked very well for me.

enter image description here

  • Hello, and welcome to Stack Exchange. Your image link is broken; would you post another? – Daniel Griscom Mar 4 '17 at 12:32
0

When you install a new one spray it with silicone spray that you can buy at the home improvement store. This will keep deposits from building up on the parts.

0

My float would stick, and the tank wouldn't fill. I did everything (almost) to fix it, even a couple things with the stem to make sure it was perfectly vertical to the hole. Nothing worked. After 2 weeks of stress and before buying a whole new thing, I pulled a hail mary pass: I nuked the head-valve with WD-40 for about 5 seconds (mostly to vent my frustration). Simply put, IT ACTUALLY WORKED. As of today, it has flushed about 50 times so far and appears to be working.

protected by Community Mar 11 at 23:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.