0

I'm trying to open this Geberit flush button in order to put anti calcarium tabs inside it, but I don't know how to.

It slides a little bit to both sides and up and down, but there's no demonstration it will open and I'm afraid to break it. How can I open it in order to have access to the water?

Thank you!

Geberit flush button

  • I have only ever worked on 1 and if I am following you those are the flush controls. The one I worked on had 2 buttons one for a dump and 1 for a pee. The other controls were for the water temp and mist or spray. I don’t think they are designed for things to be added to the tank it is enclosed or the one I was called to fix the tank was enclosed and the warm water tank had a hatch for the heater access. Not for adding chemicals. If you add the brand and model someone more knowledgeable may be able to help. – Ed Beal Oct 2 '20 at 17:09
  • @EdBeal thank you! The only thing I know this is an Geberit valve with concealed cistern. I tried to find it on Geberit catalogue and I wasn't able to. Anyway I need to open it to solve a hiss issue. Thank you for any other ideas! – LucasBr Oct 3 '20 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.