1

I just changed the filter for my National Comfort model CPG41238-U23 AC unit and now the unit is not turning on. Initially it was turning on but constantly short cycling every 30 seconds. Now the unit is only blowing air via the fan. Does anyone know why this is happening? It is a relatively new unit and it was working perfectly fine until I replaced the filter. Thanks.

The brand and model of the HVAC unit is National Comfort Brands, Model CPG41238-U23

So currently the unit says its cooling according to my thermostat but it clearly is not as the temperature on the thermostat has been at 78 all day and I have the temperature set to 70. There is no cold air coming out of the vents, just the fan seems to be on. I checked to see if the heating works and it seems to be working just fine. The cooling is just not working. I looked for the switch that dandavis mentioned and there is a switch that seems to be triggered when the slotted door to the filter is opened/closed. There is no actual switch or anything that is directly touching the filter, only the slotted door. I turned the cooling off via the thermostat and then I turned the unit off using the lightswitch located near the unit. I checked the circuit breaker and nothing was tripped. I turned off the unit via the circuit breaker, waited 1 minute then flipped the circuit back on, then turned the unit on via the lightswitch, waited for my thermostat to reboot then turned on cooling. Still no luck. Here are some attached pictures of the units filter area including the switch I Found, the thermostat reading, as well as more information about the model. Thanks again for the help.

https://imgur.com/a/c3whP4V

Also, the outside unit is not blowing out any air either.

So I consulted with some other people and they are saying that since the thermostat is on cooling, the inside vents are blowing out room temperature air, the outside unit is not blowing out any air, and the circuit breaker was not tripped, they are saying that likely the capacitor is lacking a hard start kit. Since apparently changing the filter requires opening the slotted door which causes the shut off switch to be triggered and as a result the capacitor is having a hard time starting back up without a hard start kit. If anyone agrees or disagrees please let me know, I would really appreciate it. Thanks again for all your responses!

7
  • This happened to me after refinishing a floor. It could be all frozen up inside. leave it off for a long time, maybe 12, 24 hours, and try again.
    – dandavis
    Aug 28, 2020 at 16:02
  • The thing is it was working perfectly right before I changed the filter and now its not working at all so I doubt its frozen inside.
    – Arvisionz
    Aug 28, 2020 at 16:20
  • 1
    Sometimes there is a sensor that detects air filters, often a mechanical rocker switch (actually a button) that prevents operation w/o a filter. If the filter is crooked or a slightly different size,it can prevent the switch from being clicked and thus prevent normal operation. Try jiggling.
    – dandavis
    Aug 28, 2020 at 16:26
  • Tried moving it around, even replaced it with another filter just in case. Still nothing.... so weird that it was literally working perfect right before I changed the filter
    – Arvisionz
    Aug 28, 2020 at 17:10
  • 1
    Did you bump an on-off switch (like a light switch) near or on the unit? Have you checked the circuit breaker?
    – isherwood
    Aug 28, 2020 at 20:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.