0

I have just received a set of light switches but have been unable to fit them because the small screw in the COM connector doesn't screw far enough to grip the live wire. I'm sure it must be something I am misunderstanding. Anyone offer any suggestions please?

Edited original picture to include arrows referred to in my comments below

3

Congrats on including a picture unprompted! You'd be shocked at how many people don't do that...

I presume you've stuck the wire in the plastic hole and have tightened the screw down only to discover that it doesn't touch the wire, much less hold it tightly. That's a good sign you're attempting to wire it incorrectly.

Back the screw out almost all the way. You'll see the little brass plate dropping down to create a gap. If the screw comes toward the screwdriver and the plate doesn't move, push down/wiggle on the screw until it pops loose. Now, put the wire above the brass plate and tighten the screw. That will pull the plate up and squeeze the wire in tight. This method applies, of course, to all the screw on connections, not just the COM wire.

Your switch should come with some instructions that include torque specs. You really should tighten the screw to the spec torque. If it's too loose, the wire can wiggle loose over time as the entire switch assembly moves every time you flip the switch. That looseness can begin to cause arcing and arcing can cause fires. If you can't find the torque specs on the switch itself or on the packaging/instructions, there should be some "generic" specs available online for your jurisdiction (assuming somewhere in the UK based on the "made in UK" labeling).

3
  • Thanks for your detailed response. It all made perfect sense and I went back to the switches with renewed enthusiasm. Alas nothing I do makes the bracket drop to enable a wire to be inserted. Tried with two switches and even fully removed the screws and tried pushing the bracket down with the screwdriver from above. Nothing moves at all. I've put some markings on my picture to indicate my current understanding of what you said. I was expecting that tiny gab to open up to enable me to insert the wire. – PJW Aug 17 '20 at 15:06
  • @PJW looking at your arrows, that's exactly what I would have expected to happen as well. To follow up with a potentially stupid question... Have you read the instructions? What do they say to do? – FreeMan Aug 17 '20 at 15:57
  • there were no instructions with them, other than a warning to earth the metal plate (which seems odd given they are plastic). Anyway, and I apologise for my stupidity here, but after lots of messing about, shaking, screwing and unscrewing, the screws suddenly started to go in far enough to bite down on the wires. Seems they were just very tight, or threaded badly, but they now work. Thanks for your assistance. – PJW Aug 18 '20 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.