0

We were using the hose to clean a patio and because we needed the whole length we pulled its full length out of the reel. It did not feel like anything clicked or broke when doing so, it was done in a fairly gentle way.

The problem is that the reel does not rewind the hose anymore. There is a lever button on the side to switch locked and unlocked positions but toggling it has no effect.

When trying to spin the wheel manually with the fingertips, it does not move. As if the spring is maintaining it in locked position.

What can we try?

Images here https://imgur.com/a/z9AZtxd

3
  • 2
    Sounds jammed from pulling it out to far. Have you tried rolling the reel back and forth while trying to flip the unlock/lock lever ? Do you have the manual that came with it ? Have you found the manufactures website or done any web searches to see if others have had the problem ? Is there a way to take it apart or have look inside at the mechanism ?
    – Alaska Man
    Jul 7 '20 at 22:24
  • @AlaskaMan The manual does not address this issue, or the manufacturer customer website. We have tried jittering the reel back and forth in all the lever positions. We will try again while flipping it in all its positions. There is a way to take it apart, requires a star shaped screw driver though, and I do not have one of these at the moment. Jul 8 '20 at 7:59
  • @alaska man you should make that comment an answer, I bet it will work if it’s not fubar.
    – Ed Beal
    Jul 8 '20 at 19:38
1

There seems to be many others with Hozelock reels that have problems.

fixya.com/troubleshoot/hozelock

It could be just jammed from pulling it out a little to far, not necessarily to hard but to far, or it could be the very low quality plastic parts inside have broken or the belt has broken or stripped.

If jiggling the real while jiggling the lock lever does not free it up then I think obtaining the specialty, star or torx, head screwdriver and investigating the internals is the only option to assess its repair-ability.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.