1

Samsung Chef Collection stovetop stopped detecting cookware, left two burners only. The two burners on the right are working fine. A repair guy did not mince words: take it to the dump. He said he sees these stoves failing all the time and there is very little that can be done in the way of diagnostics, short of checking for blown fuses and visually checking if something looks obviously wrong. Swapping out parts one by one can be a very expensive proposition: the cost of the part, the wait time, the time to disassemble and re-assemble the stove (there is no way to find out if it works without fully assembling it).

The fact that two burners failed at the same time provides important troubleshooting information. It is clearly not something with the individual burners - it has to be some common component shared by the left two burners.

I decided to try my luck and ordered the left inverter board. It was not cheap, around 300$ with shipping and tax. I swapped the board and... nothing.

Any ideas or suggestions what to try next? I do have a high quality tester. enter image description here

7
  • 3
    You need the circuit diagram to work out what happens where. Quite honestly the rapair man gave you good advice - you have already added $300 to the cost of your next one. Or continue with just two burners but that side may soon fail... – Solar Mike Apr 23 '20 at 5:54
  • That's the problem with these fancy appliances. They are complicated! I'm guessing there is some sort of detector that determines if you have placed a pan over the burner. Look for it and see if it can be tested. – jwh20 Apr 23 '20 at 10:33
  • 4
    I regard induction as a fad, or poorly developed technology in its infancy. As such, I think the sensible approach if you want to play with it is a countertop hotplate that does not encourage you to waste money when it breaks. You got good advice (well, actually I would have modified the advice to "use the right side only until that breaks, then take it to the dump" and chose to ignore it. Welcome to the learning experience and paying your dues. Modern electronics are mostly designed to be non-economical to repair. – Ecnerwal Apr 23 '20 at 11:19
  • 1
    @Ecnerwal - "designed to be non-economical to repair" is not strictly true. Modern electronics are designed to be cheap to produce - repairability rarely (if ever) factors into the equation one way or the other, but when it does it invariably makes the result more expensive to produce. – brhans Apr 23 '20 at 14:01
  • Are you sure you understand how these work? I ask because I doubt they actually detect the cookware but detect the load. Since you have a working side you could take comparative measurements. I don’t know how they are inducing the power to the pan high frequency or voltage I would use caution you don’t want to fry your good meter. – Ed Beal Apr 23 '20 at 14:26
5

Six weeks and 3 PCBs later...

You might want to know, was it worth it? For me, yes. It was not cheap (around $700, including repairman visit), and it took many hours. But I did save some money compared to paying for a new stove. And it gave me a feeling of satisfaction and closure, which also counts for something.

Edit, in response to comments asking for more information. So there are multiple circuit boards, some symmetrically located left and right of center, and some in the middle (the common parts between left and right sets of burners). I started out by replacing the boards on the left side, and when it did not help, I continued with the boards in the middle. In the process, we found out that the part number from Samsung for one of the boards is wrong (we spent some time on the phone with the rep from the parts vendor to establish this fact). As a result, I got one extra board to try (which did not fix the problem) that I sent back to the vendor because it was not the part that I ordered.

In the photo, you are looking at a failed solder joint. Apparently the connection became intermittent and eventually failed completely. This is on the back side of the board, so it would not be possible to catch the problem without removing the board. Also, it took a very careful examination to spot the problem.

Can I offer any advice to folks with the same problem? Not really, just a general observation that this is a very crude way to troubleshoot which is not guaranteed to be successful. Maybe start out by removing all the boards one by one and looking at them very closely in the hopes of spotting a burned-out part or a failed solder joint. If that exercise yields nothing, then start ordering replacement boards one by one. Have patience, prepare to get frustrated, and have low expectations.

enter image description here

3
  • 2
    I have the same problem with my NE58H9970WS_AA Induction Samsung Range. It looks like yours is the same range. I'm glad you fixed it! Would you outline the solution. What did you replace? Did you do any soldering? Thanks in advance. – Erlend Kimmich Dec 7 '20 at 13:22
  • 2
    A) Thanks for following up! B) Would you edit your answer to indicate what we're looking at and how you repaired it. C) Please give yourself a check mark to indicate that this has been resolved. – FreeMan Dec 7 '20 at 13:56
  • @ErlendKimmich: I just realized that I have a new inverter board and the one pictured above (pretty sure it will work if you just solder it - I can do it for you). I don't need them and I can ship them to you for free. Let me know if you want them. – user443854 Dec 29 '20 at 22:16
3

I have the same Model as you guys. My answer is the same! Mine failed at the same time as OP. But at the time, there were only 1 thread and OP was the only person that figured it out. So I was just using the right side for a whole year. Then there was this guy on youtube. https://www.youtube.com/watch?v=8IuXO3dIp-k Which showed the same problem. Then I saw many more comments and answers of the same. I bit the bullet and worked through the many screws(I also destroyed a couple) Voila!

I also found a service manual which is a very similar model minus a few screw locations. At the end, you have to completely disassemble the range to get to the board that is ruined to fix it. Took me about 2 hours total. You do need to solder a joint.

Service Manual shows in depth on how to get to it. Mind you, you don't have to remove all the assy coils to lift the coil layer, just unscrew the wires.
Page 18 shows the entire board from the top. You have to unscrew it and also pull one connector on the lower portion (or two, they have caps on them, easy to identify). If you flip it, you can find the same bad solder joint which now needs to be soldered. Ideally, you want to remove the original materials but these industrial solder joints are quite difficult to remove. So I just soldered a bunch on top of it.

https://drive.google.com/file/d/12k-uxkUmhQPmzCmY93p8YDTwaHsdaPTe/view

All in all, I think this is a design failure where the said solder joint fails for some unknown reason, maybe unbalanced current? Anyhow, Samsung should acknowledge this and make this a general knowledge.

enter image description here

3

I just want to add that I am another grateful (italian) reader of this forum that happened to stumble on it while searching info about my Samsung NZ84j9770EK induction hob (european model), suddenly not detecting cookware on the left burners, after almost three and half years of zero issues.

The induction hob

After reading al of your posts about the similarly designed (this was my guess) NE58H9970WS, I decide to disassemble my unit to see if the overall layout was consistent to the one you showed, thus leading to the same problem and solution.

As you may guess, the answer is affermative, and I think this clearly shows a design issue with all this serie of (otherwise excellent) induction units.

Possibly, the reason to the soldering fail always on the left side of the inductors could be somewhat due to the PCB layout, that is not simmetrical and could not allow heat dissipation on that spot, which I believe is not reached by the air flow of the big fan nearby. While I do not think this is a case of programmed obsoloscence, this is just my opinion.

I have been lucky enough to find the correct disassembling sequence without any service manual, which I provide below for anyone could have the same problem on this particular unit:

  • remove the 12 perimeter screws (Phillips) which join the glass surface to the electronics chassis, lift the glass and move it in a secure place;

  • remove the four connectors from the control and display board you can see in the center-bottom of the unit and move it elsewhere;

  • remove four couples of red/black thick power cables from each inductor, along with the associated tiny connector close to it;

  • remove the three tiny connectors providing power to the inductors LEDs (virtual flames), for this unit two LEDs are on the circular "burners" and one is located on the bottom of the "flexi/combo" left burners (the ones not working anymore)

  • remove 19 Phillips screws (16 perimetral and three more in the central area) plus two bigger screws on arc-shaped slots (upper right quarter of the unit);

  • lift the induction assembly and move it elsewhere;

  • access the central board (the one with six the toroidal inductors) by unscrewing 5 Phillips screws (four corners and one in the middl) and by detaching two high current connectors (they are though to extract) and a couple of smaller connectors;

The unit before removing the inductors layer

  • there you go, you do not need to detach the power cables to the board, just turn it upside down and re-solder the pin.

Just to leave a proof of how similar the defective soldering on my unit looks, compared to the original unit posted in this forum, here is the pic, and I have to say a big THANK YOU to user443854 who struggled to find the problem and finally fix it, posting his findings and helping a bunch of us. Thanks sir, great job !

enter image description here

2
  • This is really a duplicate answer and should be a comment minus the pictures. I'd VTC but it is informational. – JACK Jan 24 at 13:27
  • 1
    It is not a duplicate answer, since it applies to a different product of the the same manufacturer, which has a different aspect and overall electronic layout, yet common components to the one in the comments above. Hopefully, someone (like me) searching for help on Samsung Samsung NZ84j9770EK induction hob could (possibly) find this post useful. The first two images were added to show what product the post refers to, while the last one confirms the location of the bad weld. I just wanted to broaden the help provided by the original post. – Stefric Jan 24 at 17:05
1

I just want to say thank you so much for posting this info! I have the exact same stove (Model: NE58H9970WS). And experienced exactly what you have described. So since you showed it was possible a bad solder joint, I went ahead and started taking it apart. When I got to the board and flipped it over. Holy $#!%... It's the exact same problem. Cold solder joint on the exact same pin in your picture! So all I did was re-solder the pin (like you mentioned in a previous post). And it appears that it's working again. Boiled a couple of pots of water through out the day.

My only issue was I only have a 25W soldering iron which was not hot enough to get the pin to heat very well in order to get the solder to bond to get a nice clean solder joint. Only the wider flatter sides made good contact. The shorter side wasn't great. So I can see this problem happening again. But I'll be investing in a better soldering iron and be ready for the next time. I couldn't leave it in pieces since it was already past midnight and with kids running around not the best idea... So if you are going to try and reflow the solder, make sure you know the proper soldering techniques otherwise it will just break again if you do it poorly. And have a decent soldering iron if possible.

For reference: The IH_EMI_FILTER board has the cold solder joint

Part number: DE41-00442A

(It's the board in the middle of the stove with the 6 circle of wire coils)

And if the relay with the bad solder joint is broken, that is a GK-A-1A-12D

2
  • 1
    Welcome to Home Improvement, and I'm very happy an old Q&A here was able to help you out. That said, if you'll take the tour, you'll note that this is a Question & Answer forum and that we expect an answer in the box labeled "Answer". What you've provided is more of a comment and doesn't really answer the question, and will likely be deleted. Please say "thank you" by clicking the up arrow next to the question itself and any/all answers that have helped you. Once you've enough rep, you'll be able to add comments to other's posts. – FreeMan Jan 1 at 14:29
  • Wow. Same exact failure? I wonder if this is a factory defect, or a design flaw (e.g. temperature regime that causes the solder joint to fail). Happy to help, and thanks for the feedback. @FreeMan, I think there's useful info here, and technically it counts for an answer because it describes how to solve the problem (albeit by following another answer). If I were researching the issue, I'd find this info helpful. – user443854 Jan 4 at 20:08
1

Same problem here with the 2 left burners not detecting the pan. Fixed the bad weld and re-assembled the unit. The unit is working fine now. It took 2 hours total. Thanks.

enter image description here

1
  • Thanks for taking the time to post your answer. This could be a very useful answer if it had some context that someone else could use to diagnose and repair the problem. What circuit board is this? Where is it located? What wire is this? Where is the other end of the wire connected? How did you find this problem/solution? When you refer to "bad weld" are you meaning the solder connection between the wire and the board? – Greg Nickoloff Jan 11 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.