2

Problem:

I have a Whirlpool oven in the US, model WFG540H0ES0 (photo). It's worked fine for the last 3.5 years, but a few weeks ago the oven stopped igniting. When I start the oven in the control panel, the following sequence takes place:

  1. I can hear the gas valve open and gas starts flowing out
  2. The gas valve closes a second later, stopping the flow of gas
  3. Igniter then sparks 4 times, but by that time there is no more gas coming out

Here's a video that demonstrates the issue. I lit a candle next to the vents so you can see gas come out for a split second, but then the gas shuts off before the igniter starts sparking.

Solutions I've tried:

  • Some Youtube videos online suggested I replace the igniter, so I purchased this replacement online and installed it, but the problem is exactly the same so I know it's not the igniter.
  • I tested the thermostat by holding a candle to it. It indicates 100°F when the oven is off, and starts climbing when the flame touches it, so I know it works.
  • I've unplugged it from the wall and plugged it back again, to no avail.

I took some photos:

Questions:

  1. What is the determining part that tells the gas valve to shut off so I can clean or replace it? I know it must have a sensor that automatically shuts off the gas if a flame is not detected (to prevent flooding the house with gas), but where is this sensor? I've scoured the parts list here but I don't see anything that suggest it's a flame sensor.
  2. Does anyone have any solutions to my issue? I already replaced the spark igniter, which didn't work. I'm trying to fix the oven myself because we're in quarantine and don't want to ask a repairman to come into our house.
  • BTW: the sensor rod is part #12 in the "Chassis Parts" section of that parts list – ThreePhaseEel Apr 19 at 1:27
  • @ThreePhaseEel Are you sure? That was the thermostat that goes up in temperature when I hold a lit candle under it. I'm looking for the flame sensor that shuts off the gas when no flame is detected. – Marquizzo Apr 19 at 1:33
  • Ah, interesting. I'll have another look at the parts list...although it could be relying on temperature rise for flame sense, all the same – ThreePhaseEel Apr 19 at 2:22
2
+50

Have you considered looking at the control board and the computer system behind it? Based on what I have read and seen from what you posted, that may be the issue. I don't know for certain but it sounds like a short circuit in that area. It may have occurred if you have kids. They perhaps may have repeatedly flipped a breaker in the breaker box or it may have occurred during a power outage. It is a $243 part though, and you might want to do more research on that specifically before purchasing this part. I will post a link here if you want to look at that information I read (mainly specs on the part). https://www.searspartsdirect.com/product/1vx34izmuz-0022-664/id-w10349742 Have a good day!

New correction: I asked someone who had more experience, and he suggested that you unplug and re-plug the stove many times before considering what I suggested. Electronic systems often will exhibit symptoms such as you explained if their system is fried by a surge. For example: due to several unexpected power outages and resulting surges, our printer started to glitch, our laminator died, an expensive part in our dishwasher failed, and the motherboard in our washer was fried. Also re-read the above section for edited parts.

| improve this answer | |
  • 1
    Thanks for the suggestion! I'm worried that this might be the issue because the part is so expensive. Can you share a link to what you have read? I'd like to see if the symptoms are the same. – Marquizzo May 1 at 19:59
  • I made some edits. The other person mentioned in my edited post's reason for what he suggested was, that air bubbles may occur in the system which could cause these issues. He has run into the same problem with water heaters, furnaces, gas stoves and the like before. – Samuel May 5 at 23:35
  • 1
    You mean unplug the electricity or the gas? I don't think the gas has bubbles because the 5 stovetop ranges work fine. No sputter, no loss of pressure, nothing. – Marquizzo May 5 at 23:37
  • Electricity is what he suggested. Also re-read the above section for edited parts. – Samuel May 5 at 23:46
  • Did that answer work out for you? – Samuel May 15 at 17:53
2

I think the problem may be in the gas valve assembly (#12 on the manifold part list. In the photo taken through the drawer opening you can see just behind and slightly above the gas coupling going into the valve is what looks suspiciously like a thermopile. A thermopile is typically what is used to shut down gas flow when there is no ignition and provide consistent gas flow after ignition takes place.
I didn't see a thermopile listed in the parts so I think it may be considered part of the gas valve #W10720102.
I don't know for sure that this is the culprit but it may be.

| improve this answer | |
1

In addition to checking the control valve as others have suggested, it's possible you have low pressure or an obstruction in the gas line to the stove. Gas to an appliance is really low pressure so it doesn't take much of an obstruction to cause this.

I'm sure you've probably already visually inspected the hookup line for any crimps, but a badly crimped line or a shutoff valve that's clogged could restrict the flow enough to do that. If the line looks good on the outside, a gas pressure manometer might be needed to confirm whether you're getting enough pressure and flow at the stove.

Years ago I saw something similar happen with a furnace that was doing pretty close to what you're seeing here. It would fully light and burn for a few seconds then go out. They ultimately called the gas company to replace a filter someone had installed between the meter and the furnace. The filter fouled up and reduced the gas flow.

EDIT: I just noticed you said you can hear the gas valve open then close, and that an adjacent cooktop works fine. SO unless the hookup line is crimped I presume it's likely the electronic control unit or a bad sensor causing this instead.

| improve this answer | |
  • 1
    Thanks for the suggestion! But our stovetop range works fine. In fact, I can turn on all 5 burners on high, so it's unlikely that we have low gas pressure. – Marquizzo May 1 at 5:57
  • Yeah, right after I typed that I saw the part about the stovetop burners. Oh, well... it's nice when it's a simple issue but it rarely seems to be. – Tommy Trussell May 1 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.