2

We have a Viessmann Vitodens 200w boiler and the screen on the weather compensating control unit (Vitotronic 200 Weather Comp Kit HO1) is stuck with everything lit up.

control panel lcd all icons on

I can’t find anything in the manual about why this is, no combinations of buttons have helped, and the old off and on again trick does not fix it. The manufacturers help line won’t deal with me because the boiler is out of warranty and I’m not a licensed plumber.

Update based on comments. Pulling the fuse / circuit breaker, and indeed a local area power cut affecting 400 houses turned the boiler off, but when it came back on it was still the same. We can't be 100% sure why it wen like this, but my father in law thinks he pressed the briefcase and plus buttons at the same time and entered a test mode. But I can't find any mention of it.

Update 2 We've had various issues with the Boiler, with parts being replaced. Its had a new mainboard, new pump and new valve, but the control panel worked fine since those were installed. The Boiler is doing hot water fine, heating to radiators is underwhelming, but waiting on a pipe service, I think that is unrelated? Pressure in boiler seems fine.

How can I get it back to normal operation?

  • Have you tried to shut off the circuit breaker/pull the fuse? – Harper - Reinstate Monica Feb 8 at 15:08
  • Thanks, yeah we’ve done that, also a power cut to the area affecting 400 houses didn’t change it! – CodeMonkey Feb 8 at 15:10
  • Are you saying that the display stayed on when power was cut? Is there a backup battery that can be pulled for a full reset? – isherwood Feb 8 at 15:32
  • Hello, and welcome to Home Improvement. This wasn't always a problem, right? Any idea what triggered it? And, you should probably take our tour so you'll know how best to participate here. – Daniel Griscom Feb 8 at 15:45
  • Thanks for the follow ups, I will edit my question for better detail. @DanielGriscom is there something specifically wrong with my question? (apart from the links Javascript snuck in their when I copied and pasted, thanks iserwood for the trim!) I have an okay standing elsewhere in the network so thought it was okay? – CodeMonkey Feb 8 at 16:19
1

We got an engineer in to deal with issues outside of the scope of the question, and Viessmann support would talk to him, they pointed out that it wasn't a test mode or crash, it was the LCD brightness! Hold down the OK button, and press the minus button (-) (not originally pictured, below the plus (+)) and turn down the brightness, fixed!

| improve this answer | |
  • Well, that's not embarrassing at all! Hopefully the community appreciates the hit on my pride! lol :) – CodeMonkey Feb 22 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.