0

I just bought a new to me house, built in 1970. I replaced the old mercury thermostats with new programable digital ones. They worked great for the first 12 hours. Kept and read temps like it was set. Called for heat when needed. Then yesterday the middle floor just kept heating up. Thermostat is set at 60 but is reading 79 and heat is still coming from the radiators. I checked the zone and it does open and close manually with no issues.

Any ideas?

Update: So the thermostat will open send power to the zone valve to open, but the valve does not close. The zone valve is a White Rodgers 1311-102.

Update 2: So I just replaced the zone valve. It will open the valve, but not close it. All the wires are the same as upstairs, but the middle level will not close it. New ideas!!!

  • 2
    Are you sure the thermostats are compatible with your system? Using 24vac control is very common in heat and A/C systems, but it's not universal and some systems use other voltages/schemes. – JPhi1618 Jan 8 at 19:48
  • Yes, the thermostats are compatible. According to the packaging they came in. – Kilipaki Harris Jan 8 at 21:55
  • What are you using for thermostats? – ThreePhaseEel Jan 9 at 1:23
  • They are hunter model 44260. 24v three wire – Kilipaki Harris Jan 9 at 4:25
  • Have you tried closing the valve manually? Things do get stuck now and then, possibly just bad luck 12 hrs after the update since it is sending the close voltage. – Ed Beal Jan 9 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.