-1

In order to replace the heater element on my Miele G6510 dishwasher, I removed the whole sump assembly by removing the large worm-band and removing the filter and unscrewing the washer-jet mount. (I now know that this is not necessary - you can remove the circulation motor by just prising it out!).

When I try to reattach the sump I can not fit it over the large seal. The service manual simply says "Use rinse-agent" to lubricate it. I've tried washing up liquid without success.

I've tried all sort of ways to force it but I can't seem to apply enough pressure.

P.S. The heater element is included in the replacement part "Pump Facia"

0

The issue is probably that the o-ring has deformed making it impossible to refit.

Unfortunately, Miele only sells the o-ring as part of a new sump assembly, which costs over £50 and has to be ordered from Germany.

Fortunately, a British Standard 169.10mm inner-dimension, 185.90mm out-dimension, 8.40mm cross-section o-ring seems to be a perfect replacement.

One such supplier is https://www.altecweb.com/ product code: ORN-1691-84

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.