1

I bought FEIT replacement LED tubes at Costco, item number T48/840/LED/2, and swapped them in for fluorescent tubes (the thinner style). When I switch them on, the pairs of LEDs barely illuminate. They have an faintly-imperceptible glow but are essentially off.

When I give a good tap with my fingers on the end of the fixture on just one of the tubes in a pair, the pair of bulbs immediately lights up and stays on until I switch the lights off. Then it's back to the original state.

These are supposed to be plug-and-play bulbs with no need to bypass the fixture's ballast. The ballast says 120V/0.80A 50/60Hz, it's made by Keystone, part number KTEB-232RIS-1-TP-SL.

What might be the problem such that it is fixed every time by tapping the end of the fixture?

  • Can you find any identifying marks on the fixture's ballast as to what type of ballast it is? – ThreePhaseEel Oct 12 at 15:13
  • Hello, and welcome to Home Improvement. Guess: you're briefly interrupting the power, and the surge gets it going. Obviously, this shouldn't be necessary. Have you tried contacting FEIT support? – Daniel Griscom Oct 12 at 15:19
  • Thanks both, I've updated the post with the ballast specs and I'll try FEIT support and report back if they have any insights. – Sam Firke Oct 12 at 15:28
  • Do the bulbs feel tight in the tombstones? Are they seated properly? Do the tombstones feel loose? – Alaska Man Oct 12 at 16:21
1

Why this often doesn't work

The #1 reason this fails is that the ballas-- hold on. The #1 reason is that Feit Electric is a bunch of junk. Along with Utilitech and Lights of America, these are brands to be avoided. All of them use the "Chinese dumping" business model of disgorge staggering quantities of hastily built lights of cheap parts with little QA - knowing many will fail, but betting on the fact that very few customers bother to return low cost items.

The #2 reason is because of why they're being replaced now. The reason is that something has gone wrong with the light. The logic is, "since I have to buy tubes anyway, now's the time". This doesn't work because the lamps aren't broken, the ballast is. Plug-and-play LEDs require that you "maintain" the ballast forever. On the upside, that means you can easily rollback to real fluorescent tubes; the downside is you are paying four times the cost for a "tube" that has poorer light and only lasts twice as long as a real tube.

If you're going to maintain a ballast anyway, you might as well enjoy the 90+ CRI available from real, actual fluorescent tubes, rather than the "unspecified" from cut-corner LEDs or notchy 80 CRI from good ones.

Remember your ballast requires the smaller, narrow T8 tubes, not the fat old T12 tubes. T12 is also available in 90-98 CRI, but they are not as efficient.

Why this one didn't work

It's one of these two. Couldn't possibly guess, but the usual troubleshooting methods will work.

I would personally save myself the troubleshooting headaches of dealing with an unreliable product like Feit (always wondering if the product is the problem).

The fork in the road

First you need to establish whether the existibg ballast is any good. Try it with known-good fluorescent tubes, or other plug-n-play LEDs. If the ballast is good, you might just stand pat with real fluorescent, or PnP LED if you really want that. That ballast is a modern electronic ballast that should work in the cold, and never flicker. Though I am not a fan of the brand.

If the ballast is bad, there are two ways to go.

  • go "all-in" with LED, and remove the ballast. Now use direct-wire aka ballast-bypass LED tubes, and you will need ones that take power on opposite ends of the tube. (Some take 120V on one end, and have dummy pins on the other; they're dangerous IMO, and on yours, will require you change the tombstones also, which is just too much work.)
  • Replace the ballast with a quality one, such as GE, Advance, Philips, etc. and then use either real fluorescents for best light quality and sane tube cost, or plug-n-play LEDs.
    • If you use an instant-start ballast, it will wire up just like your current ballast; cut the wires on your dead ballast right at the ballast, and use blue wire-nuts to splice the new wires in. Now you are free to mix-and-match LEDs and real fluorescents, as the instant-start drives each tube separately.
    • If you use a rapid-start or programmed-start ballast, you will need to replace all 4 tombstones and rewire 2 wires per tube end. They drive the tubes as matched sets, so no mixing. The benefit to this on LEDs is nil, but on real fluorescents, their preheat sequence greatly extends tube life. A programmed-start crazily extends tube life to the point of being competitive with LED replacements. I use them in inaccessible locations or frequent-switch-on locations (starting a fluorescent accounts for much of the wear, so a soft-start multplies their life greatly).

The incremental cost for better brand of ballast and for rapid/programmed is much less than you'd expect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.