3

I have an old O'keefe and Merrit Oven that is not lighting. I tried contacting a local mechanic but he refused to work on it because he called it an antique. Unfortunately they simply don't seem to make ovens of this configuration any more (24" wide by 48" tall gas double) so i would like to fix it rather than have to rebuild some or all of my kitchen to get a new one in.

The oven is probably from the late 70's as that is when the house was built.

Here are the symptoms.

1) Pilot light is on 2) Pilot light is adjustable via adjustment screw 3) I hear a click when I turn the dial that should turn the oven on (sounds normal?) 4) I do not hear any gas flowing from main burner when the oven is "on" 5) Attempting to light the burner manually while oven is in on position does not work.

My assumption here is that it is a gas flow issue because if it was just the igniter then i would assume my manual lighting approach would work.

Any suggestions are welcome. and here are some pics (both from the bottom oven/broiler side)

igniter

pilot

  • Thanks for the well written question and pictures. Because you're talking about fixing an indoor gas appliance, you probably will not get anyone brave enough to help online. The wrong advice could lead to an oven filling up with gas, and that doesn't end well. Keep the door open and area well ventilated as you troubleshoot. The regulator is suspect, so you might focus on that. – JPhi1618 Oct 4 at 20:07
  • 1
    How is the flow of gas to the burner controlled -- does the dial directly (mechanically) control the valve, or is the valve electrically operated? If the latter you could test whether an ac or dc voltage appears across the wires when the gas should be flowing. – Greg Hill Oct 4 at 20:35
  • I believe it's electric. you can see two wires to the right of what i labeled "Main Jet". Also an indicator is that the control knob is no where near any of the gas stuff pictured (it's on top) i'll have to dig out my voltmeter to check – Dallas Caley Oct 4 at 21:12
1

1) Pilot light is on

If the pilot light ignites and stays lit, then it cannot be a gas supply issue, the same supply line would feed the pilot light and the main burner, it has to. But the pilot light has a device called a "thermocouple" which has a sensor that sits IN the flame and generates a small voltage when it is heated up that serves two functions; A) It signals the pilot light gas valve to turn off if the pilot light is NOT keeping it hot (meaning it was snuffed out by a guts of wind or spilled liquid or something), and B) It signals the oven burner gas supply valve that the pilot light is lit, ready to ignite the burner.

If the thermocouple is old / corroded / malfunctioning, but is still giving ENOUGH output for the PILOT valve, but not enough for the MAIN valve, or the main valve is malfunctioning and/or not getting the voltage from the thermocouple, then you will get the exact symptoms you are describing. Your knob is signalling the main valve to turn on, which is the clicking you hear, but the main valve is not responding because it is not seeing the signal telling it that the pilot light is there to igniote it, so as a safety measure, it will not allow gas to go through.

As mentioned earlier, DIY novices and gas ovens are not compatible because the result of mistakes can be deadly. I would keep trying to find a repairman that will work on your stove. But keep in mind, they may ALREADY know that it's a bad valve and they know there are no replacements available for old Okeefe an Merrit ovens.

0

You don't mention it in your post, but it would be helpful to know if it has ever worked since you've owned it, or if you acquired it like this (I'm guessing the latter). If my guess is right, and you just bought the house, check around and see if there is a shut-off somewhere before the main valve. Someone might have turned it off if the house was left vacant for any length of time. IIRC, a lot of these valves will have a position that allows the pilot to run but keeps the main burner closed off.

If that didn't work, you should probably call some more plumbers. If I was in this situation, I might attempt a little "attitude adjustment" on the main valve by giving it a few taps with a wrench (gentle taps, with the gas main to the house turned off). Natural gas is not super clean, and given the age of the unit it's possible that the value is gummed up with sediment. The vertical dead end on this piping is a trap to catch that crud:

sediment trap

If it is just clogged up, and it happens to open up, there is a good chance it will get stopped up again before too long. If that happens, the best fix is probably to have a plumber remove the valve and either clean it (assuming it is serviceable) or replace it (assuming you can find a replacement), and make sure you have a sediment trap installed before the gas enters the back of the stove.

  • Oh, good advice (i think). yes i did just purchase the house and two separate inspectors both said the oven was working (or at least didn't say that it wasn't working) i'll look for this main shutoff valve now. – Dallas Caley Oct 4 at 21:22
  • Well maybe not. I think i found where the gas comes into the house and i don't see anything like you pictured here. Also i just realized if there were some setting that only allowed the pilot lite and nothing else then i would think it would also affect my rangetop (a separate device) however this works fine. – Dallas Caley Oct 4 at 21:36
  • @DallasCaley So the range works and just the oven is broken? And any pilot lights work fine? Then Something in the oven must be stopping the gas. I'd open the whole thing up, pull out any drawers, and look around really closely for any sort of knob, button, switch etc... and try pressing it. You're looking for a reset switch that might be tripped and needs to be reset. If *that° doesn't work, i would look more closely at any thermocouples (check them with a multimeter) and the orifice on the pilot to make sure it's clear. – Z4-tier Oct 5 at 1:39
  • Also whatever mechanic called that oven an antique and refused to work is a bum. If you call a couple more, I guarantee you'll find someone that will be happy to fix it in exchange for some $$$. You could even call your gas company and see if they can send someone to help you out with it. – Z4-tier Oct 5 at 1:46
  • Last comment, I promise... If you are in a new house, please make it a priority to figure out how to shut off both the water and gas at the point where they enter the house. An emergency is a really bad time to learn. – Z4-tier Oct 5 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.