0

I'm having a weird issue with my LED track lights and I can't seem to put my finger on what exactly is causing it. They seemed to work just fine until recently. Now whenever I turn on the lights, they slowly turn on one by one and they're also super dimmed (as if operating at, say, a quarter of potential output). We don't have a dimmer AFAIK (the light switch is one of those plan-vanilla on-off switches). When I turn the lights off, they do turn off right away and don't remain turned on as in many other questions I've seen around here.

Background: we're tenants in a condo and the owner lives elsewhere. I'm pretty handy and would prefer if I could avoid calling the owner to have this fixed (will have to coordinate with one of his local handymen, etc.). Anyway, here are the specifics of the setup:

I didn't try changing the bulbs just yet in case there's a simple explanation for what's going on, plus I have no idea if that would even help given that all of them seem to work (albeit at a super-reduced output).

Anyway, I tried googling for this specific problem and couldn't find anything, so I thought I'd submit a new question here. Feel free to direct me to an existing one in case I managed to miss it. Thanks a lot!

  • 2
    Can you measure the voltage on the track as things come up? (You may need to take one of the bulbs out to do this) – ThreePhaseEel Sep 28 '19 at 23:52
  • I don't have a voltmeter on me right now, but will borrow one at work next week and try to see if measuring the voltage can get me any further. Thanks for the suggestion! – akavalar Sep 29 '19 at 1:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.