0

I really hope someone can help me solve this problem.

I have three identical toilets in my house, two have had the flushing mechanism replaced (one is still the original). Both replacements are a Dura Silent Flush mechanism. The one that was replaced most recently, has not worked really well since it was replaced… the others work fine. All the innards look identical on the two with the same (replaced) mechanisms and I have tried simply swapping the lids, to make sure it was not a button issue.

The problem is with the flush, it barely works on the half flush side and only works on the full side if you hold the button in (and, even then, the flush is not as robust as the other toilet). I can push the levers with our the lid and the toilet works.

Any clues as to what the problem might be? I am happy to send photos or video if you can help me identify the problem.

Kind regards

Lyndelle

enter image description here

enter image description here

  • 1) Would you say it is acting as if the buttons in the lid are not quite reaching the levers on the flush mechanism? If so,... 2) A photo of the levers, and one of the buttons inside the lid, might help us come up with a way to make it work. – Andrew Morton Sep 25 '19 at 14:24
  • Yes, that is a bit what it feels like (although I did swap the lids and it made no difference). I am not exactly sure if I can attach images here… do you have an email I can send them to? – Lyndelle McMillan Oct 10 '19 at 5:36
  • If you edit your question, you should see a small button with mountains - use that to add photos. (They will only appear as links to the photos until someone with enough points comes along and edits them in.) It might be that there is somewhere to adjust the position of the levers, or it might needed something added to the buttons to make them reach a little bit further. – Andrew Morton Oct 10 '19 at 8:52
  • Thanks Andrew. I have added the photos, hopefully you might be able to see if there is any way to adjust the position or suggest how to extend the length of the levers. – Lyndelle McMillan Nov 4 '19 at 4:51
  • I don't suppose you've got the installation instructions which should have come with the flush mechanism, have you? Google is not helping me with a Hardie Bathroom Products MLD 284. Without being there to wiggle the parts, I can't tell exactly which adjuster needs to be adjusted, although, referring to the second image, it looks like the white plastic part with "MLD 284" etc. on it needs to be moved, but that may make it necessary to adjust the other parts too. Or moving the straight white parts which are attached to the black parts by one hole by might do it. I might try the latter 1st. – Andrew Morton Nov 4 '19 at 9:09
0

The photo shows that some adjustments can be made by carefully taking out a plastic pin, moving the linkage a little, and putting the pin back in.

Some experimentation will show which linkage(s) to adjust; they can always be put back if there is no improvement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.